New Question
0

Set VLAN for physical network adapter in Windows

asked 2016-03-02 11:56:36 +0300

shiva-m gravatar image

I have tried setting VLAN for a net-adapter in Windows Server 2012.

If the adapter is Intel, it says not supported. Set-NetAdapter "Ethernet 2" -vlanid 1200

Output: Set-NetAdapter : Requested operation not supported on adapter 'Ethernet 2'

Incase, if this command works fine, how to bypass the execution prompt for this command. I tried using -confirm:$True, -Force parameters, its not working.

ERROR: Set-NetAdapter : A parameter cannot be found that matches parameter name 'Force'

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-03-02 12:58:00 +0300

avladu gravatar image

updated 2016-03-02 13:02:37 +0300

Hello,

First of all, according to https://technet.microsoft.com/en-us/l..., "Not all network adapters support setting the VLAN ID". In order to debug this issue, you might need to check the network card hardware information and/or your network infrastructure for VLAN support.

Secondly, Set-NetAdapter has no "Force" parameter. You can use -Confirm:$false to bypass execution prompt.

In order to get to the root cause, can you elaborate more on your use case scenario? for example, is your Windows Server 2012 already virtualized?

Thank you.

edit flag offensive delete link more

Comments

Hi. Yes, windows is virtualized. Correct, not all network adapters support vlan. But which all do support? I have pasted two net adapter properties I have tested with, one of which supports vlan tagging. http://ibin.co/2YsLoKjlhAsjhttp://ibin.co/2YsMFBU3gbYp Let me know any info required Thanks

shiva-m gravatar imageshiva-m ( 2016-03-02 17:47:38 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2016-03-02 11:56:36 +0300

Seen: 1,158 times

Last updated: Mar 02 '16