New Question
0

Rdp Console Not Working in mitaka

asked 2016-07-22 17:04:04 +0300

muthu gravatar image

updated 2016-07-22 17:08:33 +0300

Hi, I have installed Openstack Mitaka in ubuntu with openvswitch and configured Hyperv compute note to it and the setup works fine with openvswitch-hyperv-installer-beta. Thanks for this :)

Also i installed FreeRDP Webconnect. and configured the Hyperv compute node nova.conf for it.

But the console never gets shown. Its gives error like

The Instance seems to be not working. Try to enter the console again

But the instance is working fine.

The nova-consoleauth log has some warnings regarding memcached. But the memcached is running good on controller. Logs are

2016-07-21 14:25:20.302 1607 WARNING nova.context [req-1e5fb119-13b8-443e-ad69-56f8b4ed4ad0 494e92c72e3b4591aac04753d97f9223 aba78cead4624bc2b20d13483901f7f5 - - -] Arguments dropped when creating context: {u'isadminproject': True} 2016-07-21 14:25:20.303 1607 WARNING nova.consoleauth.manager [req-1e5fb119-13b8-443e-ad69-56f8b4ed4ad0 494e92c72e3b4591aac04753d97f9223 aba78cead4624bc2b20d13483901f7f5 - - -] Token: aa6b04f3-4c14-4ac2-abd3-d33b2588dab7 failed to save into memcached. 2016-07-21 14:25:20.303 1607 WARNING nova.consoleauth.manager [req-1e5fb119-13b8-443e-ad69-56f8b4ed4ad0 494e92c72e3b4591aac04753d97f9223 aba78cead4624bc2b20d13483901f7f5 - - -] Instance: 1a2be841-cbcb-477c-a176-2982f55f1a52 failed to save into memcached 2016-07-21 14:25:20.303 1607 INFO nova.consoleauth.manager [req-1e5fb119-13b8-443e-ad69-56f8b4ed4ad0 494e92c72e3b4591aac04753d97f9223 aba78cead4624bc2b20d13483901f7f5 - - -] Received Token: aa6b04f3-4c14-4ac2-abd3-d33b2588dab7, {'instanceuuid': u'1a2be841-cbcb-477c-a176-2982f55f1a52', 'accessurl': u'http://10.1.3.8:8000/?token=aa6b04f3-4c14-4ac2-abd3-d33b2588dab7', 'token': u'aa6b04f3-4c14-4ac2-abd3-d33b2588dab7', 'lastactivityat': 1469091320.302954, 'internalaccesspath': u'4F325E7A-7909-4537-8A5D-D85F150B6890', 'console_type': u'rdp-html5', 'host': u'127.0.0.1', 'port': 2179}

I believe the host should be Compute IP Address(10.1.3.8) not 127.0.0.1

Is there something someone would suggest me.

Thanks.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-07-22 17:33:14 +0300

c64cosmin gravatar image

updated 2016-07-22 17:34:16 +0300

Hello Muthu, did you install FreeRDP-WebConnect on the compute-node?(if yes, the host can be localhost, but it's not indicated). I suppose there is a problem with your openstack controller, as it should return you the proper compute-node ip. Could you enter inside Event Viewer inside the compute-node, under Application, search for source: wsgate and you should have a list of Information level entries. There are some specific ones to look for:

RDP Port:              '2179'
RDP User:              'your admin'
RDP Pcb:               '4F325E7A-7909-4537-8A5D-D85F150B6890'
RDP Host:              'some ip'

Also if there are any errors, paste those too.

Those should coincide with the info related to the particular VM you're trying to view. Also, can you show the wsgate.ini file(remove the admin password) inside

C:\Program Files\Cloudbase Solutions\FreeRDP-WebConnect\etc\wsgate.ini

edit flag offensive delete link more

Comments

Thanks for the quick reply :) Yes, i have installed FreeRDP WebConnect on Hyperv Compute node itself. I checked the EventViewer Application logs. wsgate has logs without any above information of RDP. EventViewer logs http://paste.ubuntu.com/20462454/ wsgate.ini http://paste.ubuntu.com/20463070/

muthu gravatar imagemuthu ( 2016-07-22 18:30:02 +0300 )edit

Even viewer logs has to be read from bottom. Sorry comment characters are consistent.

muthu gravatar imagemuthu ( 2016-07-22 18:31:32 +0300 )edit

Thanks for the information Muthu, it seems that FreeRDP is not able to gather the information from Openstack. Your setup seems to be correct. Can you please test if the Keystone API v2.0 is working?

c64cosmin gravatar imagec64cosmin ( 2016-07-25 16:10:29 +0300 )edit

I'am afraid NO. Command "openstack endpoint list" provides only v3 endpoints. As seen here http://paste.ubuntu.com/20882663/ . Also keystone api vertification process of v2.0 produces error as "Could not determine suitable URL for the plugin". I think in Mitaka release identity v2.0 is deprecated.

muthu gravatar imagemuthu ( 2016-07-25 19:07:38 +0300 )edit
1

Unfortunately FreeRDP doesn't support v3. I will take care of it and I will inform you as soon as it's implemented.

c64cosmin gravatar imagec64cosmin ( 2016-07-25 19:47:03 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2016-07-22 17:04:04 +0300

Seen: 370 times

Last updated: Jul 22 '16