New Question
0

Cannot launch instance on Hyper-V

asked 2016-11-24 14:33:51 +0300

Walid gravatar image

Hello all, I have a multi node openstack deployment with ( controller-neutron-compute1(KVM)). I am using the mitaka version and i used the cloudbase HyperVNovaCompute to install it on the second compute node. The kvm node is working and i am able to launch instances on it. In the dashboard and the services list, i can see the Hyper-V node and it is up and enabled. The problem is that when i try to launch an instance, i get an error : No Valid host was found. I uploaded a VHD image to glance and when i try again to launch instance, i get a disk space error. I am still confused on how should the VHD be created. Another thing, the instance at the spawning space is not getting an ip address and in the neutron logs i am getting a port binding error. Any help would be much appreciated.

Thanks

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-11-25 11:41:06 +0300

avladu gravatar image

Hello,

The Neutron Hyper-V Agent supports only flat/vlan and needs to have on the neutron api node the following dependency installed: https://pypi.python.org/pypi/networki... .

You also need to add the hyperv mechanism driver to the ml2 section from the neutron api configuration. More information you can find here: https://cloudbase.it/neutron-hyper-v-...

Thanks,
Adrian Vladu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2016-11-24 14:33:51 +0300

Seen: 80 times

Last updated: Nov 25 '16