New Question
0

SetUserPasswordPlugin failed with error 'HTTP Error 403: Forbidden

asked 2017-05-16 10:41:15 +0300

Parth Gandhi gravatar image

Hi, One of our windows VM seems to be stuck with the subjected error message in the log.

2017-05-16 07:25:29.581 2624 ERROR cloudbaseinit.init [-] plugin 'SetUserPasswordPlugin' failed with error 'HTTP Error 403: Forbidden' 2017-05-16 07:25:29.582 2624 ERROR cloudbaseinit.init [-] HTTP Error 403: Forbidden

Everytime we restart the machine we get this error and the console gets stuck with the message starting VNC handshake. Here's the complete log.

https://paste.ubuntu.com/24585709/

edit retag flag offensive close merge delete

Comments

Hello. In OpenStack, the password can be set just once. Has the password been set before to the metadata? And is this the full cloudbase-init run log? Thank you, Adrian Vladu

avladu gravatar imageavladu ( 2017-05-16 14:43:21 +0300 )edit

Hi, We use a default password build in our images using answer file. Yes, the paste contains the complete run log.

Parth Gandhi gravatar imageParth Gandhi ( 2017-05-16 15:42:19 +0300 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-05-16 22:14:20 +0300

alexpilotti gravatar image

As by Nova API documentation, the service returns 202 in case of success or 409 when the password is already set. A 403 error leads towards a configuration issue on the Nova API side. Can you check your Nova API configuration (policy.json in particular) to ensure that posting passwords is allowed?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2017-05-16 10:41:15 +0300

Seen: 32 times

Last updated: May 16