New Question
0

DNS issues with my VMs Both Windows and Linux

asked 2014-12-15 20:12:38 +0300

Aricristoles gravatar image

Hi I got 2 VM on my Open stack Ice house environment , everything is working fine, I got my floating IP working nicely
I can RDP my Windows machine and I can SSH my linux one. and from both machines I can ping 8.8.8.8.

But I cant resolve any DNS names, I have double checked all my Nodes and they can all resolve.

I don't know if this depends on me using cloud-init to create my images or not, but something is wrong.

Would appreciate any pointers on how to troubleshoot the DNS problem.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2015-01-28 03:20:26 +0300

ader1990 gravatar image

Hello,

This problem can be troubleshooted by checking the properties of your OpenStack networks.

If you use Neutron, you should check if the subnets in use have the proper DNS IPs set. In order to add a subnet with DNS, here is an example:

neutron subnet-create private 10.0.1.0/24 --dns_nameservers list=true 8.8.8.8

If you use nova-network, you can explicitly specify the DNS server that dnsmasq should use by setting the dns_server configuration option in /etc/nova/nova.conf. The following example would configure dnsmasq to use Google's public DNS server(link):

​dns_server=8.8.8.8

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Stats

Asked: 2014-12-15 20:12:38 +0300

Seen: 89 times

Last updated: Jan 28 '15