New Question
0

OpenStack nodes as virtual machines on Hyper-V, issue setting promiscuous mode, unable to ping from external network

asked 2015-05-07 13:27:42 +0300

Girish Tyagi gravatar image

Hi,

I am in middle of installing Openstack (Juno ) for first time using official installation guide but facing a blocker as mentioned below:

Issue Detail:

tenant router gateway has got the floating IP address from external network subnet but it is unreachable if I try to ping the IP from external network.

Environment:

OpenStack : Juno 14.2 OS : Ubuntu 14.04.2 LTS Nodes : Virtual Nodes over Hyper-V 2012

Port Mirroring enabled on external Network Adapter on Network Node: VM -> settings -> Network Adapter -> Advance Features -> Port Mirroring set to Destination -> Applied -> node restart.

I suspect the issue is related to not able to configure promiscuous mode on the external interface.

Thanks, Girish

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-05-07 14:30:03 +0300

alexpilotti gravatar image

updated 2015-05-07 14:30:35 +0300

If I well understood, you are running the OpenStack controller in virtual VMs on Hyper-V, while the Hyper-V host itself acts as a compute node.

For this scenario we have a deployment tool that I strongly suggest to try, as it automates completely the deployment: www.cloudbase.it/v-magine

For the promiscuous mode topic, here's a blog post that we wrote to explain how this works and how to configure Hyper-V for this use case (this is actually what v-magine does during the deployment): http://www.cloudbase.it/hyper-v-promi...

edit flag offensive delete link more

Comments

* All my OpenStack Nodes (ie Controller, Network, Compute01) are VMs on Hypre-V.
* Hyper-V host is having one physical network connection.
* I created Virtual Network Switch for (Management,Tunnel and External)

Is it possible enable promiscuous mode on VNS interface (External network) on NetworkVM

Girish Tyagi gravatar imageGirish Tyagi ( 2015-05-07 15:24:20 +0300 )edit

Please note that Hyper-V does not currently allow nested virtualization, so your Compute01 node will use QEMU emulation and not KVM, which is really not optimal.

alexpilotti gravatar imagealexpilotti ( 2015-05-07 16:59:57 +0300 )edit
0

answered 2015-05-17 20:37:15 +0300

sl-alex gravatar image

Hi! i was take this environment too, and meet this problem too. I'm solve this problem by turning on "MAC adress spoofing" on ethernet adapter for external network in parameters of the VM. All other options is leave by default. After that external networking is working fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Stats

Asked: 2015-05-07 13:27:42 +0300

Seen: 1,446 times

Last updated: May 17 '15