New Question
0

instance can not get fixed ip(VXLAN type with openvswitch on hyper-v)

asked 2015-09-25 10:10:02 +0300

Lily Xing gravatar image

I have two servers, one with Oracle Linux 7.1 as controller+network node, the other one with Windows 2012 R2 with Hyper-V as compute node. I have setup network node with VXLAN network type and installed openvswitch beta driver on hyper-v compute node. After launching an instance, everything on network node seems ok:

$ ovs-vsctl show
2c212252-1ea6-4b0d-9ead-c1f3513b9c16
    Bridge br-tun
        fail_mode: secure
        Port "vxlan-1"
            Interface "vxlan-1"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="192.168.10.10", out_key=flow, remote_ip="192.168.10.11"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
                type: internal
    Bridge br-ex
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
        Port "eno1"
            Interface "eno1"
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-int
        fail_mode: secure
        Port "tapb40d133e-f1"
            tag: 1
            Interface "tapb40d133e-f1"
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal

But there is no port created on compute node:

PS C:\Users\administrator> ovs-vsctl show
8927e0d4-fadb-48d2-8d23-f882478dcc1d
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port "vxlan-1"
            Interface "vxlan-1"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="192.168.10.11", out_key=flow, remote_ip="192.168.10.10"}
        Port "external.1"
            Interface "external.1"

Is this a bug of ported openvswitch or there are any configurations?

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2015-09-29 19:37:38 +0300

aserdean gravatar image

Hi,

You can follow the steps needed to set-up a Kilo environment, with VXLAN tunnel and neutron OVS agent on Hyper-V, in the following link: http://www.cloudbase.it/open-vswitch-...

Alin.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2015-09-25 10:10:02 +0300

Seen: 412 times

Last updated: Sep 29 '15