New Question
0

v-magine: need more than 1 value to unpack in install_hyperv_compute

asked 2015-11-08 23:58:59 +0300

NTAuthority gravatar image

updated 2015-11-09 00:00:49 +0300

Hi,

I'm trying to install V-Magine on an existing 2012 R2 Hyper-V host (without the November 2014 rollup installed; WU keeps failing on installing that - no idea if it's relevant), but I keep getting the following error after a few reboots of the virtual machine:

2015-11-08 22:49:24,085 DEBUG logging debug 1630 36148 AsyncLoopThread Sleeping for 30 seconds
2015-11-08 22:49:54,088 DEBUG logging debug 1630 36148 AsyncLoopThread connecting
2015-11-08 22:49:57,122 DEBUG logging debug 1630 36148 AsyncLoopThread connected
2015-11-08 22:49:58,494 DEBUG logging debug 1630 36148 AsyncLoopThread OpenStack config: {'oslo_messaging_rabbit': {'rabbit_hosts': '', 'rabbit_userid': '', 'rabbit_password': ''}, 'glance': {'api_servers': ''}, 'keystone_authtoken': {'admin_tenant_name': '', 'admin_password': '', 'admin_user': ''}, 'neutron': {'url': '', 'admin_auth_url': '', 'admin_tenant_name': '', 'admin_password': '', 'admin_username': ''}}
2015-11-08 22:50:29,263 ERROR logging error 1596 36148 AsyncLoopThread need more than 1 value to unpack
Traceback (most recent call last):
  File "C:\Dev\StackInABox\build\stackinabox\out00-PYZ.pyz\stackinabox.worker", line 696, in deploy_openstack
  File "C:\Dev\StackInABox\build\stackinabox\out00-PYZ.pyz\stackinabox.worker", line 346, in _install_local_hyperv_compute
  File "C:\Dev\StackInABox\build\stackinabox\out00-PYZ.pyz\stackinabox.actions", line 244, in install_hyperv_compute
ValueError: need more than 1 value to unpack
2015-11-08 22:50:29,263 ERROR logging error 1596 36148 AsyncLoopThread need more than 1 value to unpack
2015-11-08 22:50:29,263 INFO logging info 1622 36148 AsyncLoopThread Killing pybootd

In addition, the creation of the virtual machine earlier on is trying to create the controller VM with all CPU cores on the host, which causes an error as it is a dual-socket system and 'NUMA requirements' can not be satisifed - I worked around this by quickly changing the amount of vCPUs to 2 before the application tries to start the VM.

-- NTAuthority

edit retag flag offensive close merge delete

Comments

We're trying to reproduce your issue on a NUMA enabled host. The number of vCPUs is limited in recent releases, are you using the latest version?

alexpilotti gravatar imagealexpilotti ( 2015-11-10 16:48:50 +0300 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2015-11-10 12:30:39 +0300

4c74356b41 gravatar image

I'm trying to install V-Magine on an existing 2012 R2 Hyper-V host (without the November 2014 rollup installed; WU keeps failing on installing that - no idea if it's relevant) - mm, I've heard about gen2 vm with secure boot issue, you might want to disable secure boot and try to install it once again.

I've had the same error, try redownloading v-maginve. I've had no luck reproducing it after a few redownloads... but before that it kept throwing same error.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2015-11-08 23:58:59 +0300

Seen: 346 times

Last updated: Nov 10 '15