New Question
0

anyone got hyper-c to work?

asked 2016-01-25 03:55:01 +0300

scubabri gravatar image

I cant get the nano image to get past curtin. Any help would be appreciated.

edit retag flag offensive close merge delete

Comments

Hi! Can you post a few more details about what you have already tried. Feel free to edit the initial question. It would help to know: 1) what environment you are running on (bare metal, VMWare, Hyper-V, KVM, etc); 2) How you generated the nano MAAS image 3) error you get in MAAS for the node

gabriel-samfira gravatar imagegabriel-samfira ( 2016-01-25 13:39:00 +0300 )edit

On point nr 2, it would be great if you included the command line you used ( eg: \NewNanoServerImage.ps1 -IsoPath $isoPath -Platform BareMetal/VMWare/Hyper-V ). The -Platform flag is especially of interest.

gabriel-samfira gravatar imagegabriel-samfira ( 2016-01-25 13:41:01 +0300 )edit

here is the output from cloud-init-output.log. This is using the TP4 2016 ISO (same one that worked for server 2016 image) the only thing that has been changed in the script is the path to the ISO http://pastebin.com/mrtqcHwu

scubabri gravatar imagescubabri ( 2016-01-25 16:17:01 +0300 )edit

.\NewNanoServerImage.ps1 -IsoPath $isoPath -TargetPath $targetPath ` -AdministratorPassword $password -Platform BareMetal ` -Compute -Storage -Clustering -MaxSize 1500MB ` -AddCloudbaseInit -AddMAASHooks

scubabri gravatar imagescubabri ( 2016-01-25 16:19:14 +0300 )edit

The link may have been truncated EDIT: never mind. Some HTML got in the link.

gabriel-samfira gravatar imagegabriel-samfira ( 2016-01-25 16:19:52 +0300 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2016-01-25 16:39:00 +0300

gabriel-samfira gravatar image

updated 2016-01-25 16:52:54 +0300

Thanks for the pastebin!

The guide was only tested on MAAS 1.8, which was the stable version at the time of writing the blog post. You seam to be running MAAS 1.9 in your setup. It appears they moved some code around in the version of curtin that comes with maas 1.9.

Can you do an update of https://github.com/cloudbase/cloudbase-init-offline-install/tree/nano-server-support .

You need to actually update the windows-curtin-hooks submodule. The updated submodule takes into account the newer version of curtin, and should fix your issue.

git submodule update --init --recursive

should do the trick. Make sure you rebuild the nano image after you update the repo and its submodules. Let me know if you get passed that step.

EDIT: Your windows-curtin-hooks submodule should be at revision: 6eb00b48f7a9741b154d04b779f688a0d065b623

edit flag offensive delete link more

Comments

I'm setting a computer up so I can access it from my office. I'll let you know as soon as I try it out. Thanks for the quick response.

scubabri gravatar imagescubabri ( 2016-01-25 16:55:17 +0300 )edit

Ok, that worked, moving forward with an openstack deploy. Wish me luck :)

scubabri gravatar imagescubabri ( 2016-01-26 05:33:34 +0300 )edit

Awesome! Good luck!

gabriel-samfira gravatar imagegabriel-samfira ( 2016-01-26 11:43:52 +0300 )edit

Just to be clear. Do you want to deploy just openstack with hyper-v compute nodes joined to openstack, or do you want the whole hyper-converged scenario with active-directory, storage spaces direct, etc? Because if you only need a hyper-v compute enabled openstack, there are far less moving parts :)

gabriel-samfira gravatar imagegabriel-samfira ( 2016-01-26 12:07:14 +0300 )edit

is this backwards compatible with 1.8.3 maas?

scubabri gravatar imagescubabri ( 2016-01-27 04:23:11 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Stats

Asked: 2016-01-25 03:55:01 +0300

Seen: 116 times

Last updated: Jan 25 '16