New Question
0

Cloudbase-Init won't prompt user for password change first startup

asked 2016-08-01 18:50:27 +0300

kvasko gravatar image

updated 2016-08-01 18:51:02 +0300

I followed the instructions on the website to bootstrap a Windows image but I cannot figure out how to configure the image to simply ask for the user to set the password and not have a default password.

I added firstlogonbehaviour=always to my cloudbase-init.conf and cloudbase-init-unattended.conf but it doesn't seem to work. I am always prompted to enter the old password and then 2 new passwords.

Here are my configs and logs

https://gist.github.com/vaskokj/3aacd...

cloudbase-init.log: https://gist.github.com/vaskokj/b00fa...

cloudbase-init-unattended.log: https://gist.github.com/vaskokj/2715f...

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-08-08 11:26:04 +0300

Abdul gravatar image

You have to do sysprep OOBE with generalize also with shutdown. and it will reset the password before shutdown the windows.

edit flag offensive delete link more

Comments

Sorry, I'm not quite sure what you mean by that. Can you elaborate?

kvasko gravatar imagekvasko ( 2016-08-12 16:58:10 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-01 18:50:27 +0300

Seen: 187 times

Last updated: Aug 08 '16