New Question
0

ERROR : Error appeared during Puppet run: 10.121.35.3_amqp.pp

asked 2016-10-09 16:24:34 +0300

karthik gravatar image

Hi

I am getting this above error for 8 hours and the installation wont finish and continuously getting to the same point where it says : "ERROR : Error appeared during Puppet run: 10.121.35.3_amqp.pp" and then restarts puppet installation, i think it would have done some 50 times without completing the installation This is the second time I am installing the v-magine. First time it gave the same result and then i had to re start the installation.

Please give me any solution, as I am working on a POC which is time sensitive and i am unable to proceed further.

Thanks Karthik

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2016-10-12 17:32:56 +0300

danardelean gravatar image

I will ask you to add this code snippet http://paste.openstack.org/show/585463/ in v-magine installer folder -> resources -> install-rdo.sh. Add it on line 202, right after '#disable_network_manager' line.

edit flag offensive delete link more
0

answered 2016-10-10 13:15:19 +0300

danardelean gravatar image

updated 2016-10-10 13:32:47 +0300

Hi. On what Windows are your trying this? In the installer folder are 2 log files, can you please provide me the output? Also, on GUI right after the error there should be a more verbose explanation on why it failed. Thanks.

edit flag offensive delete link more
0

answered 2016-10-11 22:55:09 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

In my case, the installation is on a freshly built and patched Windows 2012 R2 server. When this occurs, here is what appears on the GUI:

10.23.68.3_amqp.pp:                               [ ERROR ]                                                                             
Applying Puppet manifests                         [ ERROR ]                                                                             

ERROR : Error appeared during Puppet run: 10.23.68.3_amqp.pp                                                                            
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install erlang' returned 1: Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-opens
tack-mitaka)                                                                                                                            
You will find full trace in log /var/tmp/packstack/20161011-221746-iEPhuN/manifests/10.23.68.3_amqp.pp.log

From the amqp.pp.log file referenced above, there appear to be a lot of dependencies missing. This is one of many listed in the file, all referring to libwx:

Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-mitaka)
Requires: libwx_gtk3u_xrc-3.0.so.0()(64bit)

aaa

edit flag offensive delete link more

Comments

Thanks for the details. I will try to reproduce this and come up with solutions. Will let you know the status.

danardelean gravatar imagedanardelean ( 2016-10-12 12:16:43 +0300 )edit

That fixed it. The install completed successfully. Thanks!

tlfunk gravatar imagetlfunk ( 2016-10-14 01:14:02 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-09 16:24:34 +0300

Seen: 151 times

Last updated: Oct 11 '16