New Question
0

A problem about neutron-hyperv-agent with GRE

asked 2016-10-25 12:23:39 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

my env:Devstack(Mitaka)+hyperV(Cloudbase Mitaka)

When the tenant network set to flat or vlan model, it does well. But as for GRE, neutron-hyperv-agent can not running.

But It should supports Flat, VLAN, GRE / NVGRE network types. How can I use GRE tenant network?

neutronhypervagent.conf:

[DEFAULT] verbose=true debug=True controlexchange=neutron policyfile=C:\Program Files\Cloudbase Solutions\OpenStack\Nova\etc\policy.json rpcbackend=rabbit logdir=E:\OpenStack\Log\ logfile=neutron-hyperv-agent.log [AGENT] pollinginterval=2 physicalnetworkvswitchmappings=*:hypervexternalvswitch enablemetricscollection=false workercount=1 [SECURITYGROUP] firewalldriver=neutron.plugins.hyperv.agent.securitygroupsdriver.HyperVSecurityGroupsDriver enablesecuritygroup=false [oslomessagingrabbit] rabbithost=192.168.135.222 rabbitport=5672 rabbituserid=stackrabbit rabbitpassword=123456 [NVGRE] enablesupport=True providertunnelip=192.168.137.66

neutron-hyperv-agent.log:

2016-10-24 21:53:15.729 3104 ERROR neutron File "C:\PROGRA~1\CLOUDB~1\OPENST~1\Nova\Python27\lib\site-packages\oswin\utils\network\nvgreutils.py", line 83, in createproviderroute 2016-10-24 21:53:15.729 3104 ERROR neutron NextHop=constants.IPV4DEFAULT) 2016-10-24 21:53:15.729 3104 ERROR neutron File "C:\PROGRA~1\CLOUDB~1\OPENST~1\Nova\Python27\lib\site-packages\oswin\utils\network\nvgreutils.py", line 131, in _createnewobject 2016-10-24 21:53:15.729 3104 ERROR neutron newobj = objectclass.new(**args) 2016-10-24 21:53:15.729 3104 ERROR neutron File "C:\PROGRA~1\CLOUDB~1\OPENST~1\Nova\Python27\lib\site-packages\wmi_init_.py", line 59, in funcwrapper 2016-10-24 21:53:15.729 3104 ERROR neutron return func(args, *kwargs) 2016-10-24 21:53:15.729 3104 ERROR neutron TypeError: new() got an unexpected keyword argument 'NextHop' 2016-10-24 21:53:15.729 3104 ERROR neutron

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-10-25 19:59:02 +0300

aserdean gravatar image

Hi,

A short answer would be NVGRE is a bit different from GRE.

Neutron-hyperv-agent does not support GRE tunnel types.

Please use neutron-ovs-agent with Open vSwitch on Windows.

Here is a quick guide how to set it up: https://cloudbase.it/open-vswitch-2-5...

For GRE just replace the line: tenant_network_type = vxlan with tenant_network_type = gre

Thank you, Alin.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-25 12:23:39 +0300

Seen: 48 times

Last updated: Oct 25 '16