New Question
0

Invalid image format 'vhdx'

asked 2017-02-23 18:36:56 +0200

roli gravatar image

Hi, I'm trying to get Nova on Hyper-V to work with vhdx Glance images. The images works well when started on Linux KVM, but on Hyper-V I get the following error in nova.log.

2017-02-21 16:38:18.236 7124 ERROR nova.compute.manager [instance: ca6e66e5-aba3-43c9-8150-9beca16e0d91] nova.exception.InvalidImageFormat: Invalid image format 'vhdx'

I can boot other images in VHD format fine on the same hypervisor. We run Newton release (via Kolla) and use the nova Windows components from https://cloudbase.it/downloads/HyperV...Newton1401.zip. Any idea what could be the cause of this? As far as I understand it vhdx should be supported.

My nova.conf looks like this:

[DEFAULT]
auth_strategy=keystone
image_service=nova.image.glance.GlanceImageService
compute_driver=compute_hyperv.driver.HyperVDriver
network_api_class=nova.network.neutronv2.api.API
volume_api_class=nova.volume.cinder.API
instances_path=C:\OpenStack\Instances
use_cow_images=true
flat_injected=true
mkisofs_cmd=C:\Program Files\Cloudbase Solutions\OpenStack\Nova\bin\mkisofs.exe
verbose=true
allow_resize_to_same_host=true
running_deleted_instance_action=reap
running_deleted_instance_poll_interval=120
resize_confirm_window=5
resume_guests_state_on_host_boot=true
rpc_response_timeout=1800
use_neutron=true
vif_plugging_is_fatal=false
vif_plugging_timeout=60
rpc_backend=rabbit
logdir=C:\OpenStack\Log\
logfile=nova-compute.log
force_config_drive=True
debug = False
transport_url = rabbit://openstack:password@10.60.11.21:5672,openstack:password@10.60.11.22:5672

[oslo_policy]
policy_file=C:\Program Files\Cloudbase Solutions\OpenStack\Nova\etc\policy.json

[oslo_concurrency]
lock_path=C:\OpenStack\Log\

[glance]
debug = False
api_servers=http://10.60.11.21:9292,http://10.60.11.22:9292

[hyperv]
vswitch_name=br-ex
limit_cpu_features=true
config_drive_inject_password=false
qemu_img_cmd=C:\Program Files\Cloudbase Solutions\OpenStack\Nova\bin\qemu-img.exe
config_drive_cdrom=true
dynamic_memory_ratio=1
enable_instance_metrics_collection=false

[rdp]
enabled=true
html5_proxy_base_url=http://10.60.11.25:8000/

[neutron]
url = http://10.60.11.201:9696

auth_strategy=keystone
project_domain_name=Default
project_name=service
user_domain_name=Default
username = neutron
password = password
auth_url = http://10.60.11.201:35357/v3
auth_type=v3password
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2017-02-23 19:03:30 +0200

alexpilotti gravatar image

The glance format is "vhd" for both vhd and vhdx

edit flag offensive delete link more

Comments

Thank you so much! That was easy when you knew it. Works just fine when you use openstack image create --file Windows-Server-2016-Standard.vhdx --container-format bare --disk-format vhd --public Windows-Server-2016-Standard-vhdx_as_vhd

roli gravatar imageroli ( 2017-02-23 20:58:29 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-02-23 18:36:56 +0200

Seen: 82 times

Last updated: Feb 23