New Question
0

can't lauch instance with Windows server 2012 image

asked 2017-05-11 18:34:46 +0300

princess94 gravatar image

I use openstack with v-magine.could you help me?

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2017-05-17 23:16:19 +0300

princess94 gravatar image

updated 2017-05-19 18:29:07 +0300

avladu gravatar image
edit flag offensive delete link more

Comments

i don't understand

princess94 gravatar imageprincess94 ( 2017-05-19 21:01:26 +0300 )edit

can you explain please?

princess94 gravatar imageprincess94 ( 2017-05-19 21:01:42 +0300 )edit
0

answered 2017-05-15 13:26:19 +0300

avladu gravatar image

Hello,

Are you using the image Windows Server 2012R2 Standard trial downloaded from cloudbase.it?

Thank you,
Adrian Vladu

edit flag offensive delete link more

Comments

YES. I m using Windows Server 2012 from cloudbase. it is impossible to launch an instance.

princess94 gravatar imageprincess94 ( 2017-05-17 14:28:32 +0300 )edit

Hello. Can you put on a pastebin the error that you are getting?

avladu gravatar imageavladu ( 2017-05-17 17:34:57 +0300 )edit

Hello. this is [Error : No valid host was found. There are not enough hosts available.]

princess94 gravatar imageprincess94 ( 2017-05-17 19:28:05 +0300 )edit

can you put in a pastebin the logs from nova hyper-v compute node? I think there is the issue. Also, are you using the vhdx image from cloudbase.it?

avladu gravatar imageavladu ( 2017-05-17 22:31:19 +0300 )edit

yes i use vdhx image

princess94 gravatar imageprincess94 ( 2017-05-17 23:03:35 +0300 )edit
0

answered 2017-05-22 20:50:53 +0300

awestin1 gravatar image

If you are getting an error that there are not enough hosts available, it could be that the cell database was not refreshed. When a compute node is added, the cell database must be refreshed.

Run the following command on your controller:

su -s /bin/sh -c "nova-manage cell_v2 discover_hosts --verbose" nova

you can also set an appropriate interval in /etc/nova/nova.conf on your controller to automatically rediscover compute nodes every so many seconds:

[scheduler]
...
discover_hosts_in_cells_interval = 300

Let me know if that works.

edit flag offensive delete link more

Comments

OK.Thank I will try it.

princess94 gravatar imageprincess94 ( 2017-05-22 22:42:46 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-05-11 18:34:46 +0300

Seen: 102 times

Last updated: May 22