New Question
0

Issue with 'Admin' password.

asked 2015-01-22 19:20:58 +0200

alexj.idig gravatar image

updated 2015-01-22 19:21:37 +0200

Hello,

We are creating customer windows images for our cloud. Currently cloudbase-init user is set to 'Admin' with 'injectuserpassword' value true. We are able to retrieve password for 'Admin' user with 'nova get-password' but for some reason that password is not working.

One thing I noticed is that 'adminPass' in the 'nova boot' command and the password retrieved using 'nova get-password ' are different and both didn't work. Customers can set 'Administrator' password from Console on first boot and it works fine.

I checked the 'cloudbase-init.log' file and there is no error when executing the ''SetUserPasswordPlugin'' plugin.

One of our customer wants to use nova API to create instances and they want to retrieve password using API.

If you could give some assistance on fixing this issue, that would be great.

Thanks for your assistance.

Alex James

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2015-01-23 17:35:50 +0200

ader1990 gravatar image

updated 2015-01-23 17:37:14 +0200

Hello,

In order to take a better look at this issue, can you provide the cloudbase-init log file and the example outputs of nova get-password?

Make sure you use the latest version of Cloudbase-Init as there was an issue with the passwords, which had been recently solved(on the 5th of January).

Thanks.

edit flag offensive delete link more

Comments

Thanks for the reply. Images were created before Jan 5th. Let us recreate the images with latest version of Cloudbase-Init and see if the issue exists.

alexj.idig gravatar imagealexj.idig ( 2015-01-23 17:44:52 +0200 )edit

Hello, We tried creating a new image with latest version of cloudbase-init but we are still facing issue with 'Admin' user password. We get blank password with nova get-password command. [root@localhost ~]# nova get-password ws2012r2std /root/.alex.pem [root@localhost ~]

alexj.idig gravatar imagealexj.idig ( 2015-01-26 16:58:27 +0200 )edit

What is the metadata provider for Cloudbase-Init? For example, ConfigDrive does not support retrieving the password. To be sure, can you provide in a pastebin the Cloudbase-Initl og files? Thanks.

ader1990 gravatar imageader1990 ( 2015-01-28 03:11:53 +0200 )edit

Hello, Thanks for getting back to me on this. We tried your image from this page and it works fine. http://www.cloudbase.it/ws2012r2/ But the image we created with new cloudbase-init package is not working. Is it possible to get a copy of the cloudbase-init package used for your image in the above link so that we can test it.

alexj.idig gravatar imagealexj.idig ( 2015-01-28 08:44:24 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-22 19:20:58 +0200

Seen: 230 times

Last updated: Jan 23 '15