New Question
0

Windows Server 2016 - ExtendVolumesPlugin¶ - doesnt work

asked 2019-10-18 17:41:11 +0200

zer023 gravatar image

2019-10-18 05:14:47.751 3152 DEBUG cloudbaseinit.metadata.services.osconfigdrive.windows [-] Looking for Config Drive vfat in cdrom getconfigdrivefiles c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\metadata\services\osconfigdrive\windows.py:197 2019-10-18 05:14:47.751 3152 DEBUG cloudbaseinit.metadata.services.osconfigdrive.windows [-] Irrelevant type vfat in cdrom location; skip _getconfigdrivefiles c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\metadata\services\osconfigdrive\windows.py:186 2019-10-18 05:14:47.751 3152 DEBUG cloudbaseinit.metadata.services.osconfigdrive.windows [-] Looking for Config Drive vfat in hdd getconfigdrivefiles c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\metadata\services\osconfigdrive\windows.py:197 2019-10-18 05:14:47.814 3152 DEBUG cloudbaseinit.utils.windows.vfat [-] Could not retrieve label for VFAT drive path '\\.\PHYSICALDRIVE0' isvfatdrive c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\utils\windows\vfat.py:46 2019-10-18 05:14:47.814 3152 DEBUG cloudbaseinit.utils.windows.vfat [-] mlabel failed with error b"init :: sector size (190) not a small power of two\r\nCannot initialize '::'\r\nC:\Program Files\Cloudbase Solutions\Cloudbase-Init\bin\mlabel: Cannot initialize drive\r\n" isvfatdrive c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\utils\windows\vfat.py:47 2019-10-18 05:14:47.829 3152 DEBUG cloudbaseinit.utils.windows.vfat [-] Obtained label information for drive '\\.\PHYSICALDRIVE2': b' Volume has no label\r\n' isvfatdrive c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\utils\windows\vfat.py:50 2019-10-18 05:14:47.829 3152 ERROR cloudbaseinit.metadata.factory [-] Failed to load metadata service 'cloudbaseinit.metadata.services.configdrive.ConfigDriveService' 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory [-] 'NoneType' object has no attribute 'group' 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory Traceback (most recent call last): 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory File "c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\metadata\factory.py", line 32, in getmetadataservice 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory if service.load(): 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory File "c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\metadata\services\configdrive.py", line 70, in load 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory searchedlocations=self.searchedlocations) 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory File "c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\metadata\services\osconfigdrive\windows.py", line 198, in getconfigdrivefiles 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory if self.getconfigdrivefiles(cdtype, cdlocation): 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory File "c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\metadata\services\osconfigdrive\windows.py", line 182, in _getconfigdrivefiles 2019-10-18 05:14:47.845 3152 ERROR cloudbaseinit.metadata.factory return getconfigdrive() 2019-10-18 05:14:47 ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2019-10-24 19:33:38 +0200

avladu gravatar image

updated 2019-10-25 17:04:16 +0200

Hello,

can you some context to the actual problem? I see an error on the config drive metadata service check.

Thank you.

[EDIT] Can you check if this patch solves the problem? https://review.opendev.org/#/c/691317/

edit flag offensive delete link more

Comments

Can you check if this patch solves the problem? https://review.opendev.org/#/c/691317/

avladu gravatar imageavladu ( 2019-10-25 17:04:21 +0200 )edit

Patch merged, please check latest version of cloudbase-init installer: https://cloudbase.it/downloads/CloudbaseInitSetup_x64.msi

avladu gravatar imageavladu ( 2019-10-30 14:21:08 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-10-18 17:41:11 +0200

Seen: 87 times

Last updated: Oct 25