New Question
0

Openstack nic not getting attached to vm switch

asked 2019-10-30 22:50:48 +0200

timco64 gravatar image

updated 2019-10-30 23:01:22 +0200

I'm using kolla-ansible rocky branch with source containers to deploy openstack. I'm running the controller as a vm on top of my hyper-v compute host. I have a vlan subnet created but the vm's nic does not get attached to a switch. I'm using windows 2016 server on the hyper-v side.

This is the relevent log from my hyperv-neutron agent.

2019-10-30 15:44:37.697 7276 DEBUG networking_hyperv.neutron.agent.layer2 [req-019bb2af-11d1-4346-8765-658f7e53d76a - - - - -] Agent loop has new devices! _work C:\Program Files\Cloudbase Solutions\OpenStack\Nova\Python\lib\site-packages\networking_hyperv\neutron\agent\layer2.py:427
2019-10-30 15:44:38.056 7276 INFO networking_hyperv.neutron.agent.layer2 [req-019bb2af-11d1-4346-8765-658f7e53d76a - - - - -] Adding port 27b64897-28b5-4177-af65-157f1f103d35
2019-10-30 15:44:38.056 7276 DEBUG networking_hyperv.neutron.agent.layer2 [req-019bb2af-11d1-4346-8765-658f7e53d76a - - - - -] Missing port_id from device details: 27b64897-28b5-4177-af65-157f1f103d35. Details: {'device': '27b64897-28b5-4177-af65-157f1f103d35', 'no_active_binding': True} _treat_devices_added C:\Program Files\Cloudbase Solutions\OpenStack\Nova\Python\lib\site-packages\networking_hyperv\neutron\agent\layer2.py:374
2019-10-30 15:44:38.072 7276 DEBUG networking_hyperv.neutron.agent.layer2 [req-019bb2af-11d1-4346-8765-658f7e53d76a - - - - -] Remove the port from added ports set, so it doesn't get reprocessed. _treat_devices_added C:\Program Files\Cloudbase Solutions\OpenStack\Nova\Python\lib\site-packages\networking_hyperv\neutron\agent\layer2.py:376

I read a bit and some suggest this is because the neutron-server does not have the networking-hyperv package. Well mine does and it's version 5.0.0 but the package on my hyperv server is 7.0.1.0rc1. I used this installer to install the openstack hyperv bits https://cloudbase.it/downloads/HyperV...Rocky1803.msi

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2019-11-04 11:59:37 +0200

lpetrut gravatar image

Hi,

Make sure to also enable the hyperv ml2 plugin as described here: https://compute-hyperv.readthedocs.io...

Now that I think of it, we'll probably want to move that section to the "prerequisites" page.

Regards, Lucian

edit flag offensive delete link more

Comments

My ml2_conf.ini has hyperv enabled and the networking-hyperv package is installed on the neutron-server. VM still does not get a hyper-v switch set.

timco64 gravatar imagetimco64 ( 2019-11-11 16:08:20 +0200 )edit

I suggest enabling debug mode for the neutron services (hyper-v as well as neutron server) and check the logs. You may search by port id, most probably this will get us to the cause of the port binding failures.

lpetrut gravatar imagelpetrut ( 2019-11-12 17:59:10 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-30 22:50:48 +0200

Seen: 31 times

Last updated: Nov 04