New Question
0

win 2012 image on OpenStack with qemu gives bsod errror

asked 2014-08-19 20:44:58 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I downloaded and attached the qcow2 image (via glance) on win2012 on my OpenStack which uses VirtualBox controller & compute nodes and thus uses QEMU. After creating an instance from the image, clicking on the 'Console' tab shows that Windows did not start up but is stuck with the 'blue screen of death' with error code 0x0000005d

Will the image work on the above environment or is it only for pure KVM (running on physical hardware) only ? Please advice. Thanks!

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2014-08-19 22:01:24 +0300

alexpilotti gravatar image

Hi, the image is for KVM and as such unfortunately does not support QEMU.

We'll have to provide a separate one for QEMU.

edit flag offensive delete link more

Comments

I am facing the same issue. I have the following openstack configuration: physical host: Ubuntu 13.10; Regular VM: Ubuntu 13.10, KVM running openstack controller/compute nodes; Nested VM: Windows Server 2012 R2 (Image downloaded from cloudbase.it) ; I believed my openstack VM instance is launched using kvm, instead of qemu. However, I am getting the same/similar error: " “Windows fail to start. A recent hardware or software change might be the cause. To fix the problem: ”

bao_pham gravatar imagebao_pham ( 2014-08-30 04:21:06 +0300 )edit

Currently, Windows is not supported by QEMU. To enable kvm acceleration: add the "--enable-kvm" flag. In nova-compute configuration file(/etc/nova/nova.conf) you must set virt_type=kvm.

ader1990 gravatar imageader1990 ( 2014-11-21 23:06:39 +0300 )edit
0

answered 2014-08-19 22:33:52 +0300

It looks like you're missing the virtio drivers. Re-launch your VM outside OpenStack or change glance properties to change the disk driver.

What I usually do is:

  • re-run the VM on my virt-manager
  • attach 2 new devices (disk and nic) and the add a new cdrom with http://alt.fedoraproject.org/pub/alt/...
  • run the VM and go to the Device Manager and install the drivers
edit flag offensive delete link more

Comments

I believed my openstack VM instance is launched using kvm, instead of qemu. However, I am getting the same/similar error: Thanks http://qwikfix.co.uk/asos-contact-number/

mariakatosvich gravatar imagemariakatosvich ( 2016-09-09 11:39:15 +0300 )edit

Cheers mate helped a lot on http://contactthedvla.co.uk

contactthedvla gravatar imagecontactthedvla ( 2016-10-04 10:50:22 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-08-19 20:44:58 +0300

Seen: 1,482 times

Last updated: Aug 19 '14