New Question
0

windows 10 hostname not set

asked 2020-12-07 13:45:06 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi,

I have see this :

https://ask.cloudbase.it/question/103...

but in my case it doesn't work.

I'm trying to deply a windows 10 (20H2) image. but the hostname is DESKTOP-xxxxx

I can see in the cloudbase-init-unattend.log : cloudbaseinit.utils.hostname [-] Setting hostname: myhostname

but when I first log on the vm, I can see that hostname is still DESKTOP-xxxx

I have verify in the unattend.xml, the cloudbase init execution is in the specialize step.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2020-12-09 15:01:36 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Sorry I don't understand

If I remove the sethostnameplugin from the unattend it will not set the hostname I want ?

I have try to put the unattend.xml like in the workaround but it seems that it is not executed (no unattend log)

edit flag offensive delete link more

Comments

It will set the hostname during the service run, provided that you have not set in cloudbase-init.conf a custom list of plugins.

avladu gravatar imageavladu ( 2020-12-14 12:06:27 +0300 )edit
0

answered 2020-12-07 14:11:29 +0300

avladu gravatar image

Hello,

This issue is a known one and you need a workaround presented here: https://ask.cloudbase.it/question/103... .

The hostname is changed by Windows 10 internal sysprep implementation and you have to remove the SetHostnamePlugin from the cloudbase-init-unattend.conf .

Thank you,

Adrian Vladu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-12-07 13:45:06 +0300

Seen: 168 times

Last updated: Dec 09 '20