New Question
0

Question about Cloudbase-init setting time

asked 2020-12-10 11:32:06 +0200

clektek gravatar image

updated 2020-12-12 16:03:53 +0200

Hello.

I created and ran a Windows instance made with OpenStack. (The instance name is "AAA") And after a 'few minutes'(about 3min~10min) after booting the instance, it was automatically rebooted.

So I confirmed that the hostname was changed to the name("AAA") of the instance I named.

I want to shorten this 'few minutes'. Is there a way to make Cloudbase-init run as soon as it finishes booting?

Thank you

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2020-12-14 11:59:48 +0200

avladu gravatar image

Hello,

In this case, I can only assume that there is no access to the HTTP OpenStack metadata service and cloudbase-init is set by default to use it and it will retry to access the HTTP metadata a number of configurable times, and only after that it uses the ConfigDrive metadata (which succeeds).

Can you share the cloudbase-init configuration file / logs for further debug and information?

Thank you,
Adrian Vladu

edit flag offensive delete link more

Comments

I found this part of log. 2020-12-16 11:22:59.717 6848 ERROR cloudbaseinit.metadata.services.ec2service [-] 503 Server Error: Service Unavailable for url: http://169.254.169.254/2009-04-04/meta-data/local-hostname

clektek gravatar imageclektek ( 2020-12-16 05:09:43 +0200 )edit

It seems that the OpenStack you use does not expose the HTTP metadata API to the instances. If it exposes the config drive one, you can set in cloudbase-init.conf, in the DEFAULT section, metadata_services=cloudbaseinit.metadata.services.configdrive.ConfigDriveService

avladu gravatar imageavladu ( 2020-12-17 14:01:35 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-12-10 11:32:06 +0200

Seen: 540 times

Last updated: Dec 14 '20