New Question
0

Cloudbase-Init 1.1.2 -- Installation failed. on Windows 2012 server R2 x64

asked 2021-04-01 23:53:21 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

How can I solve this problem? Cloudbase-Init 1.1.2 -- Installation failed. Cloudbase Solutions Srl. Installation success or error status: 1603.

detail of the unattended installation :

msiexec /i CloudbaseInitSetup112x64.msi /qn /l*v log.txt LOGGINGSERIALPORTNAME="COM1"

&&&&&&&&&&&&

=== Verbose logging started: 4/1/2021 13:50:23 Build type: SHIP UNICODE 5.00.9600.00 Calling process: C:\Windows\system32\msiexec.exe === MSI (c) (0C:64) [13:50:23:784]: Resetting cached policy values MSI (c) (0C:64) [13:50:23:784]: Machine policy value 'Debug' is 0 MSI (c) (0C:64) [13:50:23:784]: * RunEngine: * Product: CloudbaseInitSetup112x64.msi * Action: * CommandLine: ** MSI (c) (0C:64) [13:50:23:788]: Client-side and UI is none or basic: Running entire install on the server. MSI (c) (0C:64) [13:50:23:788]: Grabbed execution mutex. MSI (c) (0C:64) [13:50:23:806]: Cloaking enabled. MSI (c) (0C:64) [13:50:23:806]: Attempting to enable all disabled privileges before calling Install on Server MSI (c) (0C:64) [13:50:23:809]: Incrementing counter to disable shutdown. Counter after increment: 0 MSI (s) (A4:80) [13:50:23:813]: Running installation inside multi-package transaction C:\Users\Administrator\Downloads\CloudbaseInitSetup112x64.msi MSI (s) (A4:80) [13:50:23:813]: Grabbed execution mutex. MSI (s) (A4:10) [13:50:23:816]: Resetting cached policy values MSI (s) (A4:10) [13:50:23:816]: Machine policy value 'Debug' is 0 MSI (s) (A4:10) [13:50:23:816]: * RunEngine: * Product: C:\Users\Administrator\Downloads\CloudbaseInitSetup112x64.msi * Action: * CommandLine: ** MSI (s) (A4:10) [13:50:23:820]: Machine policy value 'DisableUserInstalls' is 0 MSI (s) (A4:10) [13:50:23:820]: Note: 1: 2203 2: C:\Windows\Installer\inprogressinstallinfo.ipi 3: -2147287038 MSI (s) (A4:10) [13:50:23:827]: SRSetRestorePoint skipped for this transaction. MSI (s) (A4:10) [13:50:23:831]: Note: 1: 1402 2: HKEYCURRENTUSER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 3: 2 MSI (s) (A4:10) [13:50:23:831]: File will have security applied from OpCode. MSI (s) (A4:10) [13:50:23:863]: SOFTWARE RESTRICTION POLICY: Verifying package --> 'C:\Users\Administrator\Downloads\CloudbaseInitSetup112x64.msi' against software restriction policy MSI (s) (A4:10) [13:50:23:863]: SOFTWARE RESTRICTION POLICY: C:\Users\Administrator\Downloads\CloudbaseInitSetup112x64.msi has a digital signature MSI (s) (A4:10) [13:50:23:990]: SOFTWARE RESTRICTION POLICY: C:\Users\Administrator\Downloads\CloudbaseInitSetup112x64.msi is permitted to run at the 'unrestricted' authorization level. MSI (s) (A4:10) [13:50:23:990]: MSCOREE not loaded loading copy from system32 MSI (s) (A4:10) [13:50:23:990]: End dialog not enabled MSI (s) (A4:10) [13:50:23:990]: Original package ==> C:\Users\Administrator\Downloads\CloudbaseInitSetup112x64.msi MSI (s) (A4:10) [13:50:23:990]: Package we're running from ==> C ... (more)

edit retag flag offensive close merge delete

Comments

Can you please paste the log in a pastebin and add the link to your post instead of the whole log? thanks

alexpilotti gravatar imagealexpilotti ( 2021-04-21 15:39:34 +0300 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2021-04-22 00:49:26 +0300

avladu gravatar image

Hello,

From the logs, I could see that the installation exits with error code 1603: https://docs.microsoft.com/en-us/trou...

From Microsoft's docs:

You may receive this error message (1603) if any one of the following conditions is true:

Windows Installer is attempting to install an app that is already installed on your PC. The folder that you are trying to install the Windows Installer package to is encrypted. The drive that contains the folder that you are trying to install the Windows Installer package to is accessed as a substitute drive. The SYSTEM account does not have Full Control permissions on the folder that you are trying to install the Windows Installer package to. You notice the error message because the Windows Installer service uses the SYSTEM account to install software.

Can you give more information on the environment where you tried to install cloudbase-init? As a baseline, make sure that the system has the latest updates and you do have a clean / new environment.

Thank you,
Adrian Vladu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-04-01 23:53:21 +0300

Seen: 230 times

Last updated: Apr 22