New Question

Cloudbase-init localscript exitcode 1003 won't restart [closed]

asked 2022-05-13 12:50:47 +0300

s-cappa gravatar image

I created a powershell script, but when I add "exit 1003" it won't restart the VM automatically. I'm using windows server 2019 with all the latest updates. I run cloudbase-init with service: "NoCloudConfigDriveService".

The problem seems like this: but I didn't understand the solution.

I configured cloudbase-init with "allow_reboot=true" in both cloudbase-init.conf and cloudbase-init-unattend.conf. I added "cloudbase.plugins.common.locascripts.LocalScriptsPlugin" as plugin in cloudbase-init.conf. Then I executed Sysprep.exe with "/generalize /oobe /shutdown /unattend:Unattend.xml".

When I start the windows server 2019 VM, Cloudbase-init creates users, network config and runs Localscript as expected, but It won't restart ad "exit 1003"

Which are the required config parameters to enable automatic reboot returning 1003 as exit code from a local script?

Thank you.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by s-cappa
close date 2022-05-17 09:48:24.064908

1 answer

Sort by » oldest newest most voted

answered 2022-05-13 13:06:36 +0300

s-cappa gravatar image

Oh, I forgot to say that I'm using cloudbase-init 1.1.3 dev

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2022-05-13 12:50:47 +0300

Seen: 371 times

Last updated: May 13 '22