New Question
0

Cloudbase-init won't apply config file after sysprep

asked 2024-02-07 17:08:17 +0200

ali2k4000 gravatar image

updated 2024-02-09 11:30:51 +0200

avladu gravatar image

Hi, all. I'm running a packer build for Windows Server core and am running into an issue with cloudbase-init. In my build, I'm installing cloudbase-init with the MSI, then copying custom config files into the proper locations. I've added the unattend.xml to the one I am using for Windows. The syntax for the unattend.xml is correct as I have validated with the SIM tool. After sysprep is ran, I upload the ova into AWS and create an instance from it. The instance has the user 'cloudbase-init' created instead of the one in the config file. The config files that I had copied are in the correct locations but they aren't being applied. Is there a step I am missing here?

Thanks

Hi, all. I'm running a packer build for Windows Server core and am running into an issue with cloudbase-init. In my build, I'm installing cloudbase-init with the MSI, then copying custom config files into the proper locations. I've added the unattend.xml to the one I am using for Windows. The syntax for the unattend.xml is correct as I have validated with the SIM tool. After sysprep is ran, I upload the ova into AWS and create an instance from it. The instance has the user 'cloudbase-init' created instead of the one in the config file. The config files that I had copied are in the correct locations but they aren't being applied. Is there a step I am missing here?

Thanks

Hi, all. I'm having an issue with cloudbase that I'm hoping someone can help me with. I'm creating an ova with a packer build but for some reason, the conf files are not applying. In my build, I'm installing the msi, then copying the files into the correct location and the final step is sysprep. I've added the unattend.xml in the cloudbase files to my sysprep unattend. When deploying a new server from my packer build the conf files are not applied at all. The only way I can get them to apply is to do the re arm (removing the registry key that resets cloudbase). Am I missing a step?

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2024-02-09 11:35:39 +0200

avladu gravatar image

Hello,

the user cloudbase-init is created by the installer and not related to the config files and you can choose to not create during the installation.

Related to the config files not being applied, there are two cloudbase-init runs at the first boot, one during sysprep specialize(cloudbase-init-unattend.conf) and one after oobe (cloudbase-init.conf). Afterwards, at any subsequent reboot, there is one run per boot.

Can you please provide the config files/unattend and maybe some cloudbase-init logs, if possible?

Thank you.

edit flag offensive delete link more

Comments

Hi. I've attached the script I run for cloudbase-init to install and copy the config files and the actual config files themselves. https://drive.google.com/file/d/1gNeYEOxy2eerpRfn6IN-sOldl7vGZXSg/view?usp=sharing It doesn't work unless i delete the cloudbase registry key and restart the service

ali2k4000 gravatar imageali2k4000 ( 2024-02-09 18:30:04 +0200 )edit

Hello, the gdrive url is not public, can you please make it public?

avladu gravatar imageavladu ( 2024-02-12 13:03:59 +0200 )edit

Hi. I've made the url public.

ali2k4000 gravatar imageali2k4000 ( 2024-02-12 17:13:58 +0200 )edit

To add another note, i'm doing a silent install (msiexec /i cloudbase-init.msi /qn), are there options i should specify here to make it work correctly?

ali2k4000 gravatar imageali2k4000 ( 2024-02-12 18:12:06 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2024-02-07 17:08:17 +0200

Seen: 45 times

Last updated: Feb 09