New Question
0

Error when add external port (vSwitch Hyper-v) no OVS

asked 2015-04-02 23:27:46 +0300

leogemeostotino gravatar image

Follow the error:

PS C:\Users\Administrator> ovs-vsctl.exe add-br br0 PS C:\Users\Administrator> PS C:\Users\Administrator> PS C:\Users\Administrator> PS C:\Users\Administrator> ovs-vsctl.exe add-port br0 external ovs-vsctl: Error detected while setting up 'external'. See ovs-vswitchd log for details. PS C:\Users\Administrator> PS C:\Users\Administrator>

PS C:\Users\Administrator> ovs-vswitchd log 2015-04-02T23:10:12Z|00001|reconnect|INFO|log: connecting... 2015-04-02T23:10:12Z|00002|reconnect|INFO|log: connection attempt failed (Unknown error) 2015-04-02T23:10:12Z|00003|reconnect|INFO|log: waiting 1 seconds before reconnect 2015-04-02T23:10:13Z|00004|reconnect|INFO|log: connecting... 2015-04-02T23:10:13Z|00005|reconnect|INFO|log: connection attempt failed (Unknown error) 2015-04-02T23:10:13Z|00006|reconnect|INFO|log: waiting 2 seconds before reconnect 2015-04-02T23:10:14Z|00007|fatal_signal|WARN|terminating with signal 2

No Hyper-v, the OVS extension is activate:

PS C:\Users\Administrator> Get-VMSwitchExtension external

Id : EA24CD6C-D17A-4348-9190-09F0D5BE83DD Name : Microsoft NDIS Capture Vendor : Microsoft Version : 6.3.9600.16384 ExtensionType : Monitoring ParentExtensionId : ParentExtensionName : SwitchId : b92de3fe-773d-4bcd-8fc4-ebf583e3ed28 SwitchName : external Enabled : False Running : False ComputerName : WIN-N7Q2QKOG2KG Key : IsDeleted : False

Id : E7C3B2F0-F3C5-48DF-AF2B-10FED6D72E7A Name : Microsoft Windows Filtering Platform Vendor : Microsoft Version : 6.3.9600.16408 ExtensionType : Filter ParentExtensionId : ParentExtensionName : SwitchId : b92de3fe-773d-4bcd-8fc4-ebf583e3ed28 SwitchName : external Enabled : True Running : True ComputerName : WIN-N7Q2QKOG2KG Key : IsDeleted : False

Id : 583CC151-73EC-4A6A-8B47-578297AD7623 Name : Open vSwitch Extension Vendor : Open vSwitch Version : 15.12.39.857 ExtensionType : Forwarding ParentExtensionId : ParentExtensionName : SwitchId : b92de3fe-773d-4bcd-8fc4-ebf583e3ed28 SwitchName : external Enabled : True Running : True ComputerName : WIN-N7Q2QKOG2KG Key : IsDeleted : False

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2015-04-20 21:22:34 +0300

aserdean gravatar image

updated 2015-04-20 21:23:57 +0300

The issue is caused by outdated documentation. The following lines:

ovs-vsctl.exe add-br br0

ovs-vsctl.exe add-port br0 external

are now

ovs-vsctl.exe add-br br0

ovs-vsctl.exe add-port br0 external.1

ovs-vsctl.exe add-port br0 internal

This will allow external traffic.

Alin.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-04-02 23:27:46 +0300

Seen: 520 times

Last updated: Apr 20 '15