New Question
0

Remote OVS query

asked 2015-04-05 02:17:03 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

We use OVS in Linux and some white box switches that are controlled by our controller. I installed OVS-for-Hyper-v and was able to attach to the controller, and the controller could see the switch:

C:>ovs-vsctl show

9ff8ebf7-5c0f-4983-897f-48dd9590ae38

Manager "ptcp:6640"
Bridge "br0"
    Controller "tcp:10.0.6.40:6653"
        **is_connected: true**
    fail_mode: secure
    Port external
        Interface external
    Port "br0"
        Interface "br0"
            type: internal

I can query the database locally:

C:>ovs-vsctl list port

_uuid : aea852cd-32b6-4d3b-83b4-147249295cfb

bondactiveslave : [] bonddowndelay : 0 bondfakeiface : false bondmode : [] bondupdelay : 0 externalids : {} fakebridge : false interfaces : [9443c892-5adc-4edb-861b-6205d99e6840] lacp : [] mac : [] name : external otherconfig : {} qos : [] rstpstatistics : {} rstpstatus : {} statistics : {} status : {} tag : [] trunks : [] vlan_mode : []

uuid : e39d9bda-d20d-40ec-96a8-fab9c14d4041 bondactiveslave : [] bonddowndelay : 0 bondfakeiface : false bondmode : [] bondupdelay : 0 externalids : {} fakebridge : false interfaces : [adb19ce2-5c60-42e5-97cb-1c29cf3df22f] lacp : [] mac : [] name : "br0" otherconfig : {} qos : [] rstpstatistics : {} rstpstatus : {} statistics : {} status : {} tag : [] trunks : [] vlanmode : []

But if I try that remotely using the "ovs-vsctl --db=tcp:10.0.6.114:6640 list port" ,the connection says it is getting refused. I disabled the windows firewall, so that should not be the issue.

Any ideas on what I am doing wrong?

Thanks

edit retag flag offensive close merge delete

Comments

Figured it out. Had to make a registry change to add the --remote=pctp:6640 to allow access under ovs-vswitchd --> Imagepath

Neteng1 gravatar imageNeteng1 ( 2015-04-07 06:12:03 +0300 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2015-04-20 21:17:38 +0300

aserdean gravatar image

That is one way to do it.

Simpler would be to set the manager. I.e: ovs-vsctl set-manager ptcp:6640 ovs-vsctl set-manager tcp:1.2.3.4:6640

edit flag offensive delete link more
0

answered 2015-04-08 20:36:00 +0300

Neteng1 gravatar image

Figured it out. Had to make a registry change to add the --remote=pctp:6640 to allow access under ovs-vswitchd --> Imagepath

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-04-05 02:17:03 +0300

Seen: 117 times

Last updated: Apr 20 '15