New Question
0

Problem with userdata module

asked 2015-05-05 18:16:12 +0200

stban1983 gravatar image

Hi, I set the module "cloudbaseinit.plugins.windows.userdata.UserDataPlugin" in my cloudbase configuration file like this: plugins=cloudbaseinit.plugins.windows.userdata.UserDataPlugin

But when i deploy my VM, i have this error in the Cloudinit log: ImportError: No module named userdata and cloudinit didnt work, the hostname didn't change.

Any ideas ? (same problem on a 2008R2 and a 2012R2)

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2015-05-05 18:35:32 +0200

alexpilotti gravatar image

Can you please post the full log in pastebin or paste.openstack.org and paste the link here?

Thanks

edit flag offensive delete link more

Comments

stban1983 gravatar imagestban1983 ( 2015-05-05 18:50:41 +0200 )edit
0

answered 2015-05-05 19:06:09 +0200

alexpilotti gravatar image

the userdata plugin has been moved from windows to to common

edit flag offensive delete link more
0

answered 2015-05-05 18:51:44 +0200

stban1983 gravatar image
edit flag offensive delete link more

Comments

https://github.com/stackforge/cloudbase-init/blob/master/cloudbaseinit/plugins/common/factory.py#L32

alexpilotti gravatar imagealexpilotti ( 2015-05-05 19:05:45 +0200 )edit

Great! Many thanks I will test and let you known if it's working! Edit: it's ok! thank you Alexpilotti

stban1983 gravatar imagestban1983 ( 2015-05-05 19:08:44 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-05-05 18:16:12 +0200

Seen: 384 times

Last updated: May 05 '15