New Question
0

v-magine "need more than 1 value to unpack"

asked 2015-10-26 11:07:39 +0300

4c74356b41 gravatar image

updated 2015-10-26 11:10:30 +0300

Hello, so I've tried to install OpenStack with v-magine on 2012r2 and win10, both installations always (I've tried like dozen times) end with this same error ("need more than 1 value to unpack"). I haven't even found logs for v-magine to troubleshoot it. Any advice please?

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-10-26 11:21:45 +0300

alexpilotti gravatar image

Thanks for reporting this issue, we're going to replicate your scenario and reply ASAP.

2 log files get generated in the v-magine folder, both have .log extensions.

edit flag offensive delete link more

Comments

Tell me you did something, else I feel like a madman. Somehow it started working on my 2012r2... At least I got to the puppet part, lets see... I'll try on vNext and post here

4c74356b41 gravatar image4c74356b41 ( 2015-10-26 18:10:54 +0300 )edit

i guess you can mark this as answered, I have no idea, it installs fine now everytime.

4c74356b41 gravatar image4c74356b41 ( 2015-10-28 12:52:26 +0300 )edit
0

answered 2015-10-26 12:05:33 +0300

4c74356b41 gravatar image

updated 2015-10-26 12:14:24 +0300

Well, you would not believe it, this time I got past this error on my Win10 (I changed nothing I swear). But on my 2012r2 I've tried this install like 10 times minimum. Thank you for telling me about the log files, I was searching in all the temp dirs., oh well. Right now its doing something with puppet on centos, I hope it works out well.

ps. Just so you know, win10 RTM (10240) won't create VMSwitches when trying to install, I worked around that by creating switches manually (commented on that here > http://www.cloudbase.it/v-magine/).

I'll keep this thread updated.

edit flag offensive delete link more

Comments

Well, it installed... I guess I can call that a miracle. I will be installing 2016tp3 in the evening and trying out new install, I'll tell you how it goes.

4c74356b41 gravatar image4c74356b41 ( 2015-10-26 13:05:52 +0300 )edit

It installed on the latest tp of vnext, but it is really inconsistent. it was working on 2012 r2, I reformatted my box, installed 2016, did a fresh install of openstack, it stopped working (some ridiculous error about vhd not being vhd)...

4c74356b41 gravatar image4c74356b41 ( 2015-10-27 16:30:17 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-26 11:07:39 +0300

Seen: 118 times

Last updated: Oct 26 '15