New Question
0

Can use directly 'metadata' server IP instead of 169.254.169.254

asked 2014-09-29 18:46:29 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Is it possible to configure 'Cloudbase-init' to use 'metadata' server IP (ex. 10.123.2.3) instead of 169.254.169.254? In 'clould-init', 'metadataurl' can be specified in 'cloud.cfg' configuration file. Is it possible to specify 'metadataurl' in 'cloudbase-init.conf' configuration file?

Thanks, Tae

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2014-10-02 23:23:31 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

After setting the options as below, it was able to pull down the metadata from the metadata server.

The correct config options are:

metadata_base_url=http://YourServer

ec2_metadata_base_url=http://YourServer

Thanks, David

edit flag offensive delete link more
0

answered 2014-09-29 19:19:07 +0200

alexpilotti gravatar image

It is definitely possible, for OpenStack HTTP metadata just specify in cloudbase-init.conf and cloudbase-init-unattend.conf:

metadatabaseurl=http://yourserver/

For EC2 metadata, the config option is: ec2metadatabase_url

edit flag offensive delete link more

Comments

Even after adding 'metadatabaseurl=http://MyServer/' and 'ec2metadatabase_url=http://MyServer/' to 'cloudbase-init.conf', it is still trying to get metadata from http://169.254.169.254. Are there any options I need to spcify? Is there the documentation for configuration file. http://1drv.ms/YUEtw8

davidkkim gravatar imagedavidkkim ( 2014-10-02 22:11:02 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-09-29 18:46:29 +0200

Seen: 215 times

Last updated: Oct 03 '14