New Question
0

Cannot find compute service

asked 2015-12-30 08:59:45 +0300

Lily Xing gravatar image

updated 2016-01-01 15:39:40 +0300

I setup a controller+network node on Oracle Linux(Kilo), and install a hyper-v compute node following cloudbase doc. But after installation, I can find neutron hyper-v agent, but no related compute services. And I checked that table compute_nodes in nova database is empty. Any idea?

compute service is running correctly on windows 2012 R2. No error message reported on either compute node or controller node.

compute-node.log as below:

2015-12-30 09:46:21.717 2624 INFO oslo_messaging._drivers.impl_rabbit [req-e3650168-e7d4-4d2b-8a44-7c9f504f3248 - - - - -] Connecting to AMQP server on 192.168.12.20:5672
2015-12-30 09:46:21.733 2624 INFO oslo_messaging._drivers.impl_rabbit [req-e3650168-e7d4-4d2b-8a44-7c9f504f3248 - - - - -] Connected to AMQP server on 192.168.12.20:5672
2015-12-30 09:46:21.749 2624 INFO oslo_messaging._drivers.impl_rabbit [req-e3650168-e7d4-4d2b-8a44-7c9f504f3248 - - - - -] Connecting to AMQP server on 192.168.12.20:5672
2015-12-30 09:46:21.763 2624 INFO oslo_messaging._drivers.impl_rabbit [req-e3650168-e7d4-4d2b-8a44-7c9f504f3248 - - - - -] Connected to AMQP server on 192.168.12.20:5672
2015-12-30 09:46:21.826 2624 WARNING oslo_config.cfg [req-e3650168-e7d4-4d2b-8a44-7c9f504f3248 - - - - -] Option "lock_path" from group "DEFAULT" is deprecated. Use option "lock_path" from group "oslo_concurrency".
2015-12-30 09:46:26.059 2624 WARNING nova.compute.resource_tracker [req-0833d144-8cd2-48b4-a6f8-d23fe59fe102 - - - - -] No compute node record for COMPUTE-NODE1:COMPUTE-NODE1
2015-12-30 09:46:26.282 2624 INFO oslo_messaging._drivers.impl_rabbit [req-0833d144-8cd2-48b4-a6f8-d23fe59fe102 - - - - -] Connecting to AMQP server on 192.168.12.20:5672
2015-12-30 09:46:26.299 2624 INFO oslo_messaging._drivers.impl_rabbit [req-0833d144-8cd2-48b4-a6f8-d23fe59fe102 - - - - -] Connected to AMQP server on 192.168.12.20:5672

The root cause seems I tried using MTU 9000. When I use the default MTU=1500, it works well. But whenever I use MTU 9000, it doesn't work.

What I have updated:

dnsmasq.conf:
dhcp-option-force=26,8950

l3_agent.ini:
[DEFAULT]
network_device_mtu = 8950

ml2_conf.ini:
[ml2]
path_mtu = 8950
segment_mtu = 8950`

nova.conf:
[DEFAULT]
network_device_mtu = 8950

How could I enable mtu 9000?

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2016-02-14 10:21:20 +0300

Lily Xing gravatar image

It is caused by the mismatch mtu settings. After I changed them to support MTU 9000, it works.

edit flag offensive delete link more
0

answered 2015-12-30 18:41:41 +0300

alexpilotti gravatar image

Hi, this is related most probably to configuration issues in the hyper-v nova.conf

Can you please post the content of c:\openstack\log\nova-compute.log?

Thanks,

Alessandro

edit flag offensive delete link more

Comments

Hi Alessandro, I have updated compute logs. Thanks.

Lily Xing gravatar imageLily Xing ( 2015-12-30 20:05:16 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-30 08:59:45 +0300

Seen: 142 times

Last updated: Feb 14 '16