New Question
0

V-Magine install fails (downloading rdo-release-kilo-1.noarch.rpm)

asked 2016-05-18 10:04:24 +0300

Jonas gravatar image

Hi all,

I try to install V-Magine on a Hyper-V server 2012 R2. The installation fails when it tries to download the following file: https://repos.fedorapeople.org/repos/... In https://repos.fedorapeople.org/repos/... I can find rdo-release-kilo-2.noarch.rpm but not rdo-release-kilo-1.noarch.rpm What can i do to solve this problem?

Kind Regards, Jonas

edit retag flag offensive close merge delete

Comments

Still broken for me as well :(..............any file we can edit the path in?

Hugo gravatar imageHugo ( 2016-06-01 04:02:34 +0300 )edit

5 answers

Sort by » oldest newest most voted
0

answered 2016-07-01 14:08:22 +0300

updated 2016-07-01 14:12:21 +0300

You must edit install-rdo.sh file from v-magine/resources:

  • at line 180 change epel-release version to the latest that you find here. So as of 01.07.2016 it's version 7.7

exec_with_retry 5 0 /usr/bin/rpm -Uvh http://download.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-7.noarch.rpm

  • and then change at line 185 with latest rdo-release-kilo that can be found here. Again, as of 01.07.2016 it's version 2

RDO_RELEASE_RPM_URL=https://repos.fedorapeople.org/repos/openstack/openstack-kilo/rdo-release-kilo-2.noarch.rpm

edit flag offensive delete link more
0

answered 2016-06-03 11:32:16 +0300

Jonas gravatar image

updated 2016-06-03 11:33:14 +0300

Changing the RDO_RELEASE_RPM_URL value in install-rdo.sh from $1 to https://repos.fedorapeople.org/repos/... solved the problem. Thanks Avladu for the solution.

edit flag offensive delete link more
0

answered 2016-07-01 16:35:09 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

i am installing V-machine in hyper V, getting the same error. I already change the /resources/install-rdo.sh, but during the install the installer show the old URL. I try run install-rdp.sh direct in VM open-stack-controller but receive lot of error.

edit flag offensive delete link more
0

answered 2016-06-02 16:01:57 +0300

avladu gravatar image

Hello,

As a quick fix, you can update v-magine/resources/install-rdo.sh, line 180, to:

exec_with_retry 5 0 /usr/bin/rpm -Uvh http://download.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-6.noarch.rpm

Thanks.

Adrian.

edit flag offensive delete link more

Comments

Hi Adrian, Thanks for the reply! I don't need te epel-release-7-6.noarch.rpm file but rdo-release-kilo-1.noarch.rpm. Kind regards, Jonas

Jonas gravatar imageJonas ( 2016-06-02 17:40:47 +0300 )edit

You can change RDO_RELEASE_RPM_URL=$1 to RDO_RELEASE_RPM_URL=https://repos.fedorapeople.org/repos/openstack/openstack-kilo/rdo-release-kilo-2.noarch.rpm

avladu gravatar imageavladu ( 2016-06-02 18:58:32 +0300 )edit

Hi, Thanks for the information. Changing the RDO_RELEASE_RPM_URL value in install-rdo.sh solved my problem.

Jonas gravatar imageJonas ( 2016-06-03 11:28:33 +0300 )edit
0

answered 2016-06-01 18:36:27 +0300

same problem

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Stats

Asked: 2016-05-18 10:04:24 +0300

Seen: 655 times

Last updated: Jul 01 '16