New Question
0

OVS 2.5.1 Tunnel Problem, No Network inside VM

asked 2016-12-10 21:16:26 +0300

semka_mesilov gravatar image

Hello, After updating OVS 2.5.0.1 to 2.5.1 no vxlan tunnels can't be created automaticaly within br-tun. To check we can remove all VM from host so OVS will have no tunnels to the other agents. Then we create a new VM and OVS tells failed to query port : Invalid argument when tries to get tunnels. I'm using OVS 2.5 on neutron server.

2016-12-10T19:07:48.249Z|00106|dpif|WARN|system@ovs-system: failed to query port : Invalid argument 2016-12-10T19:07:48.877Z|00107|bridge|INFO|bridge br-int: added interface 25b5cc64-b59f-4624-8bdf-def533e354f6 on port 3

I'd be more than happy if you can help me with this issue.

[DEFAULT] controlexchange=neutron policyfile=C:\Program Files\Cloudbase Solutions\OpenStack\Nova\etc\policy.json verbose=true logdir=C:\OpenStack\Log\ logfile=neutron-ovs-agent.log rpcbackend=neutron.openstack.common.rpc.implkombu rabbithost=db-server rabbitport=5672 rabbituserid=nova rabbitpassword=compaq

[ovs] localip = 172.17.4.111 bridgemappings=isp1:br-ex tunnelbridge = br-tun integrationbridge = br-int tenantnetworktype = vlan,vxlan enable_tunneling = true

[agent] pollinginterval=2 tunneltypes = vxlan l2_population = True

[SECURITYGROUP] enablesecuritygroup = False

ovs-vsctl show 13128f31-ae60-47b0-b614-6af878234f81 Bridge br-tun failmode: secure Port br-tun Interface br-tun type: internal Port patch-int Interface patch-int type: patch options: {peer=patch-tun} Bridge br-ex failmode: secure Port br-ex Interface br-ex type: internal Port vxlan tag: 4 Interface vxlan type: internal Port "port2vlans" Interface "port2vlans" Port phy-br-ex Interface phy-br-ex type: patch options: {peer=int-br-ex} Bridge br-int fail_mode: secure Port int-br-ex Interface int-br-ex type: patch options: {peer=phy-br-ex} Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} Port "25b5cc64-b59f-4624-8bdf-def533e354f6" tag: 1 Interface "25b5cc64-b59f-4624-8bdf-def533e354f6" Port br-int Interface br-int type: internal

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
1

answered 2016-12-10 22:44:21 +0300

semka_mesilov gravatar image

Problem closed. Found solution.

edit flag offensive delete link more
0

answered 2016-12-12 14:56:33 +0300

aserdean gravatar image

Hi,

I was wondering what was the solution after the upgrade.

It will help us understand better if we need to add documentation or address the actual issue.

Thanks, Alin.

edit flag offensive delete link more

Comments

1

Hi, Alin. Solution is to add some configuration options to agent section. of_interface = ovs-ofctl ovsdb_interface = vsctl There is another problem with lost interface TAG in OVS after Live Migration. https://bugs.launchpad.net/compute-hyperv/+bug/1644122

semka_mesilov gravatar imagesemka_mesilov ( 2016-12-12 15:00:21 +0300 )edit

Thanks for the update! We are currently addressing the native implementation and give you an update when we added it to our installers. Regarding the live migration issue, from the logs it seems that the port name is not set prior adding it to OVSDB. I will try to sync with Claudiu on the topic.

aserdean gravatar imageaserdean ( 2016-12-14 06:53:27 +0300 )edit

Hi, Alin. Thanks. Wait you update.

semka_mesilov gravatar imagesemka_mesilov ( 2016-12-15 10:26:25 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Stats

Asked: 2016-12-10 21:16:26 +0300

Seen: 98 times

Last updated: Dec 12 '16