New Question
0

Hyper-v Open vSwitch agent not working

asked 2016-12-14 00:39:35 +0300

tahder gravatar image

updated 2016-12-14 00:41:43 +0300

I used to follow the article Open vSwitch 2.5 on Hyper-V (OpenStack) but seems not working the openvswitch as I could not get it in the neutron from the controller node (via neutron agent-list command) but the Hyper-v compute node is working well (via nova service-list command) in the controller node.

By the way software that I use, OpenStack Newton 1.1 (in the controller node-separate server). In Hyper-v server - HyperVNovaCompute_Newton 14.0.1 and openvswitch hyperv 2.5.1 certified (or even tried openvswitch hyperv 2.6.1 certified).

I am stuck in the part of the article that mentioned "Note: creating a service manually for the OVS agent won’t be necessary anymore starting with the next Nova Hyper-V MSI installer version. Here is the content of the neutron_ovs_agent.conf file:" as it mentioned not necessary anymore but seems not created a file, even tried to copy the same configurations as per stated and this is my configuration(C:\Program Files\Cloudbase Solutions\OpenStack\Nova\etc\neutronovsagent.conf)

[DEFAULT]
verbose=true
debug=false
control_exchange=neutron
policy_file=C:\Program Files\Cloudbase Solutions\OpenStack\Nova\etc\policy.json
rpc_backend=neutron.openstack.common.rpc.impl_kombu
rabbit_host=10.20.30.203
rabbit_port=5672
rabbit_userid=guest
rabbit_password=guest
logdir=C:\OpenStack\Log\
logfile=neutron-ovs-agent.log
[agent]
tunnel_types = vxlan
enable_metrics_collection=false

[SECURITYGROUP]
enable_security_group=false
[ovs]
local_ip = 10.20.30.254
tunnel_bridge = br-tun
integration_bridge = br-int
tenant_network_type = vxlan
enable_tunneling = true

But it doesn't show me up, with the bridge/port such as br-int, patch-tun, br-tun, patch-int et al.. But only show me these, where ens5 is my network name.

PS C:\Users\Administrator> ovs-vsctl show
42842d57-2c30-4f59-a258-7ab149768d66
    Manager "ptcp:6640:127.0.0.1"
    Bridge "br-port1"
        Port "ens5"
            Interface "ens5"
        Port "br-port1"
            Interface "br-port1"
                type: internal

And the logs I got only these in c:\OpenStack\Log\neutron-ovs-agent.log

2016-12-13 17:40:56.226 2688 INFO neutron.common.config [-] Logging enabled!
2016-12-13 17:40:56.226 2688 INFO neutron.common.config [-] C:\Program Files\Cloudbase Solutions\OpenStack\Nova\Python27\Scripts\neutron-openvswitch-agent-script.py version 9.0.1.dev14
2016-12-13 17:40:56.242 2688 WARNING oslo_config.cfg [-] Option "rabbit_host" from group "DEFAULT" is deprecated. Use option "rabbit_host" from group "oslo_messaging_rabbit".
2016-12-13 17:40:56.242 2688 WARNING oslo_config.cfg [-] Option "rabbit_host" from group "oslo_messaging_rabbit" is deprecated for removal.  Its value may be silently ignored in the future.
2016-12-13 17:40:56.242 2688 WARNING oslo_config.cfg [-] Option "rabbit_port" from group "DEFAULT" is deprecated. Use option "rabbit_port" from group "oslo_messaging_rabbit".
2016-12-13 17:40:56.242 2688 WARNING oslo_config.cfg [-] Option "rabbit_port" from group "oslo_messaging_rabbit" is deprecated for removal.  Its value may be silently ignored in the future.
2016-12-13 17:40:56.242 2688 WARNING oslo_config.cfg [-] Option "rabbit_password" from group "DEFAULT" is deprecated. Use option "rabbit_password" from group "oslo_messaging_rabbit".
2016-12-13 17:40:56.256 2688 WARNING oslo_config.cfg [-] Option "rabbit_password" from group "oslo_messaging_rabbit" is deprecated for removal.  Its value may be silently ignored in the future.
2016-12-13 17:40:56.256 2688 WARNING oslo_config.cfg ...
(more)
edit retag flag offensive close merge delete

Comments

Hello Alin, It seems not working adding those 2 lines. I don't know if this related to the nova.conf configurations as per checking with the compute node using kvm they have slight differences under [neutron] section.. auth_plugin=v3password (in hyper-v) auth_type=v3password (in kvm)

tahder gravatar imagetahder ( 2016-12-14 02:27:21 +0300 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2016-12-15 05:25:21 +0300

tahder gravatar image

Hi aserdean,

It seems working right now, what I did remove cloudbase-related software by uninstalling

HyperVNovaCompute_Newton 14.0.1 and openvswitch hyperv 2.5.1 certified

And stop/remove the running service (neutron-ovs-agent) and stop/disable neutron-hyperv-agent. Then remove the Hyper-V (as this is Microsoft :-) ).

After boot-up, install back the HyperVNovaCompute and openvswitch but this case using 2.6.1 do the steps on the article, add per your your solution ofinterface & ovsdbinterface and change the VM Switch extension to (take note of Cloudbase):

Get-VMSwitchExtension -VMSwitchName vSwitch -Name "Cloudbase Open vSwitch Extension"
Enable-VMSwitchExtension -VMSwitchName vSwitch -Name "Cloudbase Open vSwitch Extension"

As per checking on the logs, it seems on the first run br-int is created but it will stop suddenly the neutron-ovs-agent service. Solution is to rerun it or reboot on my case which then automatically created those bridges/ports br-tun, patch-int, xvlan-* et al after reboot.

My controller now is happy and able to see the Hyper-V Open vSwitch agent and Hyper-v nova-compute.

Thanks a heap, MBC

edit flag offensive delete link more

Comments

I'm glad you got it to work :). That is some pretty weird behaviour. Just for my curiosity could you please post the `ovs-vswitchd.log` and the output of systeminfo on pastebin.com? Thanks.

aserdean gravatar imageaserdean ( 2016-12-16 04:42:20 +0300 )edit

are you referring to the hyperv neutron_ovs_agent.log? which is this one http://pastebin.com/tc2BYnw6

and in the controller (openvswitch-agent.log?) http://pastebin.com/9bQjmBEZ

which I found error on ofctl..

tahder gravatar imagetahder ( 2016-12-19 23:53:30 +0300 )edit

ovsdb-server.log/ovs-vswitchd.log (OVS specific logs) and the output from an elevated cmd in which you run systeminfo. Thanks

aserdean gravatar imageaserdean ( 2017-01-06 18:08:02 +0300 )edit
0

answered 2016-12-14 01:52:55 +0300

aserdean gravatar image

Hi tahder,

Thanks for reaching out!

Unfortunately, you will still have to create the 'neutron-ovs-agent' service manually. Thanks for pointing the flaw in the documentation. We will update it.

Since Mitaka you will have to add the following lines in 'neutronovsagent.conf':

[ovs]
...
of_interface = ovs-ofctl 
ovsdb_interface = vsctl

The above will switch from native implementation to exec calls.

We are currently addressing the issue and I will update this answer once it was integrated.

Let me know if the above fixes the issue.

Thanks, Alin.

edit flag offensive delete link more

Comments

Tried to reboot and got these: http://paste.openstack.org/show/592285/ pls do remove "< / p>" as it added in the url.

tahder gravatar imagetahder ( 2016-12-14 02:49:33 +0300 )edit

Looks like br-int does not exist. Could you please post an output from ovs-vsctl show and also issue the following command: ovs-vsctl.exe --no-wait del-manager

aserdean gravatar imageaserdean ( 2016-12-14 05:43:31 +0300 )edit

I tried to execute the command, and got this still not shown in neutron ovs-vsctl show 42842d57-2c30-4f59-a258-7ab149768d66 Bridge "br-port1" Port "ens5" Interface "ens5" Port "br-port1" Interface "br-port1" type: internal Bridge br-int

tahder gravatar imagetahder ( 2016-12-14 11:05:27 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2016-12-14 00:39:35 +0300

Seen: 147 times

Last updated: Dec 15 '16