New Question
0

freerdp-webconnect IIS reverse proxy

asked 2015-12-18 05:19:23 +0300

joshgx gravatar image

updated 2015-12-18 05:22:32 +0300

Hello

I'm trying to setup FreeRDP-WebConnect through an IIS proxy using URL Rewrite so it is accessible outside my LAN without exposing additional ports in my firewall besides 80 and 443.

Here is the issue:

When accessing the page through the re-written url everything seems to work correctly with the exception of the websocket.

looking at the HTML, it seems that the %WSURI% (var wsBase) is coming back as ws://localhost:8000/wsgate instead of using the external url. Im at a loss and would like to know if anyone knows how to remedy this by chance?

Here is a screenshot https://drive.google.com/file/d/0B5XV...

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-06-02 23:58:41 +0300

c64cosmin gravatar image

You will need to replace all %TAG% strings with the ones that are required, one very easy way is to use wsgate and see what web source files it replies and then replace as seen there, or use those files entirely.

Thank you, Cosmin.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Stats

Asked: 2015-12-18 05:19:23 +0300

Seen: 273 times

Last updated: Jun 02 '16