New Question
0

How can i add remotefx 3d video adapter to vm with openstack command

asked 2016-01-12 11:59:00 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have an vm running on hyperv 2012 r2. how can i add remotefx option to it with openstack api.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2016-11-11 17:36:31 +0300

Claudiu Belu gravatar image

Hello,

Make sure you have enabled the RemoteFX feature on your compute nodes, by setting this config flag in the nova.conf file:

[hyperv]
enable_remotefx = True

Also, make sure you install the RemoteFX feature on your compute nodes:

Install-WindowsFeature RDS-Virtualization

Also, you have to make sure that your hosts are capable of the RemoteFX feature. Some of the requirements are:

  • SLAT-enabled processor (Intel: Extended Page Tables (EPT), AMD: Nested Page Tables (NPT)).
  • it must support DirectX 11.0 or newer.
  • it must support WDDM 1.2 or newer.

Also, you have to make sure that your guests support RemoteFX. For a Windows guest, you can easily check this by looking at its Device Manager > Display Adapters, it should be something like: Microsoft RemoteFX Graphics Device - WDDM.

Finally, we've added support for RemoteFX in Windows / Hyper-V Server 2016, which comes with new features. Some of the new features for RemoteFX in Windows / Hyper-V Server 2016 are:

  • 4K resolution option
  • 1GB dedicated VRAM (availble choices: 64MB, 128MB, 256MB, 512MB, 1GB) and up to another 1GB shared VRAM
  • Support for Generation 2 VMs
  • OpenGL and OpenCL API support
  • H.264/AVC codec investment
  • Improved performance

In order to request a certain VRAM memory amount for your instance, you can create a flavor like this:

# format: resolution,number_of_monitors,vram_amount_in_mb
nova flavor-create m1.remotefx 111 4096 20 2 nova flavor-key 11 set hyperv:remotefx="1920x1200,1,1024"

Best regards,

Claudiu Belu

edit flag offensive delete link more
0

answered 2016-01-12 18:16:26 +0300

First of all you have to make sure you use the compute hyperv driver. You can check this by looking in c:\ProgramFiles (x86)\CloudbaseSolutions\Openstack\Nova\etc\nova.conf and see if compute_driver = hyperv.nova.driver.HyperVDriver

In order to use RemoteFX you have to create a new flavor in Openstack with the following extra-spec: {"hyperv:remotefx": "1920x1200,1"}. In this case, it means that your vm will have remotefx enabled with 1920x1200 resolution and 1 monitor. Eg:

nova flavor-create m1.remotefx 111 4096 20 2 nova flavor-key 11 set hyperv:remotefx="1920x1200,1"

By doing this, you create a new flavor for remotefx enabled machines.

After this, you just have to boot a new machine with this flavor and it will have a remotefx video adapter.

Note that the valid resolution values for 2012R2 are: 1024x768, 1280 ×1024, 1600 ×1200, 1920 ×1200 and the maximum number of monitors is 4 for resolutions up to 1280x1024, 3 for 1600x1200 and 2 for 1920x1200.

Thank you,

Adelina

edit flag offensive delete link more

Comments

Thank you Adelina, I created the flavor as you point me but it not work. # nova flavor-create m1.remotefx 111 7168 80 2 #nova flavor-key 111 set hyperv:remotefx="1920x1200,1" # nova boot --flavor m1.remotefx --image testWindows --nic net-id=c07.... testVM

ahmad gravatar imageahmad ( 2016-01-25 18:28:22 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Stats

Asked: 2016-01-12 11:59:00 +0300

Seen: 927 times

Last updated: Nov 11 '16