New Question

Revision history [back]

click to hide/show revision 1
initial version


The Windows client versions have, for security reasons, the Administrator account disabled by default, therefore cloudbase-init and imaging tools do not change the default behavior because that means less secure systems. You can find here a more complete security assessment on what are the implications:

Nonetheless, if you prefer to manage Windows client VMs as you manage Windows Server VMs, you can enable the Administrator account by putting in a powershell LocalScript or userdata:

net user Administrator /active:yes

More on this here:

On Windows 10, due to a known Windows bug. please make sure you address the hostname set issue presented here:

I do not understand this line: "I can log in with the old Admin password, so it seems that the password is not getting overwritten." Can you give more information on this? As there should not be any Admin user created before the first cloudbase-init run, thus no "old" password. Any cloudbase-init logs and cloudbase-init configurations can be very useful to debug/understand your issue.

Thank you, Adrian Vladu