New Question

Revision history [back]

click to hide/show revision 1
initial version


This problem can be troubleshooted by checking the properties of your OpenStack networks.

If you use Neutron, you should check if the subnets in use have the proper DNS IPs set. In order to add a subnet with DNS, here is an example:

neutron subnet-create private --dns_nameservers list=true

If you use nova-network, you can explicitly specify the DNS server that dnsmasq should use by setting the dns_server configuration option in /etc/nova/nova.conf. The following example would configure dnsmasq to use Google's public DNS server(link):