New Question

Revision history [back]

click to hide/show revision 1
initial version


First of all, with the latest changes in cloudbase-init code, some plugins have been moved to a new namespace. Make sure you have the appropriate plugins definition in your cloudbase-init.conf file. Latest code can be found here: . For example:

  • -> cloudbaseinit.plugins.common.sethostname.SetHostNamePlugin

Secondly, I would suggest to use the cloudbase-init installer Sysprep option(without checking the automated Shutdown option), as it takes care of running cloudbase-init unattend. After you run sysprep, update the cloudbase-init.conf and cloudbase-init-unattend.conf according to your needs and shutdown the vm.

Hope it helps.