New Question

Revision history [back]

click to hide/show revision 1
initial version


At a first glance, it looks like metrics collection was not enabled for that instance. In order to enable metrics collection, you will have to have enable it in the configuration files:

  • for nova, for compute related metrics like cpuusage, memoryusage, diskread, diskwrite, disk_iops, etc., in nova.conf, in the hyperv section:

  • for neutron, for networking related metrics, in neutron_hyperv_agent.conf, in the AGENT section:


By default, those config options are set to true if you have used our installer and chose to install the ceilometer-agent-compute as well. Otherwise, they are set to false.

Another important note, if the nova config option was false and you've set them to true, the nova-compute service will not enable the metrics collection for any pre-existing instance. neutron-hyperv-agent will turn on metrics collection for all bound ports.

If, for some reason, this issue persists and there are still missing metrics, there might be some errors enabling metrics collection. In this case, please include the nova-compute.log and neutron-hyperv-agent.log files.

Best regards,

Claudiu Belu