New Question

Revision history [back]

First of all you have to make sure you use the compute hyperv driver. You can check this by looking in c:\ProgramFiles (x86)\CloudbaseSolutions\Openstack\Nova\etc\nova.conf and see if compute_driver = hyperv.nova.driver.HyperVDriver

In order to use RemoteFX you have to create a new flavor in Openstack with the following extra-spec: {"hyperv:remotefx": "1920x1200,1"}. In this case, it means that your vm will have remotefx enabled with 1920x1200 resolution and 1 monitor. Eg:

nova flavor-create m1.remotefx 111 4096 20 2 nova flavor-key 11 set hyperv:remotefx="1920x1200,1"

By doing this, you create a new flavor for remotefx enabled machines.

After this, you just have to boot a new machine with this flavor and it will have a remotefx video adapter.

Note that the valid resolution values for 2012R2 are: 1024x768, 1280 ×1024, 1600 ×1200, 1920 ×1200 and the maximum number of monitors is 4 for resolutions up to 1280x1024, 3 for 1600x1200 and 2 for 1920x1200.

Thank you,