New Question
0

Win2012 boot error on Openstack in Vmware env

asked 2016-05-19 14:26:51 +0300

serena_extra gravatar image

updated 2016-05-19 14:29:02 +0300

I have Openstack (1 controller and 2 computes) installed in 3 VM on Vmware ESXI environment, only for testing purposes. On this nodes, virt-what gives "vmware". Linux instances start successfully, but no luck with Windows.

I downloaded the Eval KVM version of Windows Server 2012 made by Cloudbase and uploaded it in glance using the following, as suggested on your website: glance image-create --property hypervisortype=qemu --name "Windows Server 2012 R2 Std Eval" --container-format bare --disk-format qcow2 < /path/windowsserver2012r2standardevalkvm20151021.qcow2 .

When I launch the instance and open the Console, I get status 0xc0000001. I read a lot about that but I cannot find a solution which fits for me. I would like to know if the problem is related to this specific vmware environment, because the image is for KVM and not vmware virtualization.

In compute /etc/nova/nova.conf I have virt_type=qemu, If I change it in "kvm" even Linux instances don't start anymore.

Thanks a lot for any advice!

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-05-19 17:58:46 +0300

avladu gravatar image

Hello,

Windows cannot run as a VM on qemu-kvm without hardware acceleration. When you have in nova compute nova.conf "virt_type=qemu", the processor capabilities exposed by qemu without hardware acceleration are not on par with the Windows processor requirements.

The solution in your case is to enable nested virtualization for the Linux machine, in the corresponding .vmx configuration file, by adding:

 vcpu.hotadd = "FALSE"
 featMask.vm.hv.capable = "Min:1"
 vhv.enable = "TRUE"

Make sure you remove (not delete) the Linux machine from the ESXi inventory, edit the .vmx accordingly and open the .vmx afterwards.

After this step, you can set "virt_type=kvm" and resume the instance spawning.

Thanks, Adrian.

edit flag offensive delete link more

Comments

Hi Adrian, thanks a lot. It seems clear, I'll try it. Just to be sure: I have 3 virtual machine running on Esxi (1 controller and 2 compute nodes), should I repeat this procedure you explained on each Linux machine? Or only for compute nodes?

serena_extra gravatar imageserena_extra ( 2016-05-19 18:04:52 +0300 )edit

It is required only for the compute nodes, so that you can enable the nested virtualization.

avladu gravatar imageavladu ( 2016-05-19 18:25:32 +0300 )edit

Thanks Adrian, it worked and Windows Server started successfully. While restarting preexisting Linux instances instead, we experienced kernel panic error. We need to recreate them from images. Is it normal due to the virt_type change?

serena_extra gravatar imageserena_extra ( 2016-05-20 12:43:56 +0300 )edit

Great! About the Linux instances, I do not know if this is the expected behavior, as qemu is used just for testing scenarios (or when there is no hardware support) and not for production.

avladu gravatar imageavladu ( 2016-05-20 13:46:00 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-05-19 14:26:51 +0300

Seen: 409 times

Last updated: May 19 '16