Requirements and ContextualVersionConflict

asked 2016-06-27 12:18:47 +0200

Gyeol Yu gravatar image

updated 2016-06-30 09:32:20 +0200


I'm writing to ask for technical questions. Our team are testing about cinder-volume kilo for Windows Server. (OS: Windows server 2012 R2 standard)

We installed OpenStack Cinder Volume for Windows Server using wizard that you provide. (CinderVolumeSetupKilo201510.msi)

But, service was not started with 1067 error.

In other ways, we tried to start using python scripts. then, appeared error message.

[Error message] File ".... \", line 838, in resolve raise VersionConflict(dist, req).withcontext(devpendentreq) pkgresources.DistributionNotFound: The 'oslo.vmware=0.11.1' distribution was not found and is required by cinder

So, we tried to restart after install requirement modules (We used command as follows "pip install -r $~Openstack\Python27\Lib\site-packages\cinder-2015.1.0-py2.7.egg-infor\requires.txt") Likewise, service was not started with pkg_resources.ContextualVersionConflict error in pbr module.

-Error message pkg_resources.ContextualVersionConflict: (pbr 0.11.1 (c:\program files (x86)\cloudbase solutions\openstack\python27\lib\site-pakages), Requirement.parse('pbr=pbr1.3'), set(['sqlalchemy-migrate']))

We retried after reinstall cinder volume kilo and python packages, but there was same problem.

What should we do with this problems? Please give me a solution.

edit retag flag offensive close merge delete