New Question
0

Install fail "need more than 1 value to unpack"

asked 2016-10-01 03:48:48 +0200

eckdd gravatar image

updated 2016-10-01 03:49:45 +0200

Ran this on the latest release of Server 2016, then installed 2012 R2 and got the same thing. Looks like it bombs out after the following:

 2016-09-30 11:18:52,552 DEBUG logging debug 1630 4728 AsyncLoopThread OpenStack config: {'oslo_messaging_rabbit': {'rabbit_hosts': '', 'rabbit_userid': '', 'rabbit_password': ''}, 'glance': {'api_servers': ''}, 'keystone_authtoken': {'admin_tenant_name': '', 'admin_password': '', 'admin_user': ''}, 'neutron': {'username': '', 'project_name': '', 'url': '', 'user_domain_name': '', 'auth_url': '', 'password': '', 'project_domain_name': ''}}

2016-09-30 11:19:24,816 ERROR logging error 1596 4728 AsyncLoopThread need more than 1 value to unpack

Here's the rest of the log: http://pastebin.com/L9ZZuxj0 console log: http://pastebin.com/CM5Aq4Gp Prior to this, CentOS rebooted after installing the Linux Integration Services. It fails after the exact same event in both 2012R2 and 2016.

edit retag flag offensive close merge delete

Comments

Tryed with Hyper-V Server 2012R2 and 2016 - Same errors. Tryed re-download installers - unpack with different archivizers - without result :/ I'm stucked .... https://s11.postimg.org/ivlsa6nsz/image.jpg

ITgeek gravatar imageITgeek ( 2016-11-10 00:16:09 +0200 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2016-10-03 13:47:16 +0200

danardelean gravatar image

Hi. It looks like the there were some variables that were not passed on correctly. Do the 2 logs from 2016 and 2012 R2 look the same, fail at the same step? Can you please try and run the installer with Administrator privileges? Also, how much RAM does the host and the VM have? Thanks.

edit flag offensive delete link more

Comments

I did not notice any differences between the 2012 R2 log and the 2016 log; both fail in the same place and give the same error. Ran the install as both the local admin and separate account with admin rights. VM has 6144 MB with 16 cores assigned, host has 128 GB, dual 8 core Opteron 6212's.

eckdd gravatar imageeckdd ( 2016-10-03 21:39:49 +0200 )edit

Also dropped the core count down to 4 right before the VM powered on and it failed in at the same place with same error.

eckdd gravatar imageeckdd ( 2016-10-03 21:41:13 +0200 )edit

Hi. Please do the following on the CentOS VM: 1. When the installer fails, do not exit it 2. Connect to the CentOS VM console 3. Run this script http://paste.openstack.org/show/584199/ 4. Put the following parameters to the script 'python script.sh [IP] [username] [password]'

danardelean gravatar imagedanardelean ( 2016-10-04 16:14:47 +0200 )edit

The IP must be the external IP of the VM, 'mgmt-ext' interface in 'ip a' e.g. python script.sh 10.7.1.97 root admin

danardelean gravatar imagedanardelean ( 2016-10-04 16:19:31 +0200 )edit

The IP must the external IP of the VM, 'mgmt-ext' interface in 'ip a' e.g. "python script.sh 10.7.1.97 root admin"

danardelean gravatar imagedanardelean ( 2016-10-04 16:24:52 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-10-01 03:48:48 +0200

Seen: 265 times

Last updated: Oct 03 '16