New Question
0

unable to download the nano server package on new nano server

asked 2017-05-08 12:02:04 +0300

Parth Gandhi gravatar image

Hi , I just installed our first nano server on our openstack compute node (hypervisor- KVM) and set the proxy of the nano server using the below code:

$proxy = 'myproxy' $port = myportno $regKey='HKLM:\Software\Microsoft\Windows\CurrentVersion\Internet Settings' Set-ItemProperty -path $regKey ProxyEnable -value 1 -ErrorAction Stop Set-ItemProperty -path $regKey ProxyServer -value "${Proxy}:${Port}" -ErrorAction Stop

However when i run install-packageprovider nanoserverpackage, it gives me an error related to internet connection. WARNING: Unable to download the list of available providers. Check your internet connection i had to download the package on a local machine - copy it to nano using Copy-item and then install it. Is there a way to connect to the proxy from nano server - download -install?

Thanks.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2017-05-08 15:57:50 +0300

avladu gravatar image

Hello,

I do not have any other information than what's currently available on a Google search:

https://social.technet.microsoft.com/...

https://github.com/PowerShell/xNetwor...

And the PS code above does not have a meaning on Nano, as there is no IE feature/application available for nano.

I will get back with some more information on this topic, as there might be some equivalent to the IE setting.

Thank you,
Adrian Vladu

edit flag offensive delete link more

Comments

Thanks @avaladu. I did check the above two links before. I am also looking out on the solution.

Parth Gandhi gravatar imageParth Gandhi ( 2017-05-08 16:05:28 +0300 )edit

You can do like this: https://paste.ubuntu.com/24536721

avladu gravatar imageavladu ( 2017-05-08 16:22:17 +0300 )edit

The resource seems to be delete or does not exist.

Parth Gandhi gravatar imageParth Gandhi ( 2017-05-09 10:10:30 +0300 )edit

You need to make sure the modified code above works without the proxy and then try to use the proxy field.

avladu gravatar imageavladu ( 2017-05-09 17:33:24 +0300 )edit

@parth: The paste link was improperly formatted by the portal/CMS. Try removing the '/<\/p/>' from the end. This link should work: `https://paste.ubuntu.com/24536721`

awestin1 gravatar imageawestin1 ( 2017-05-09 21:56:48 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-08 12:02:04 +0300

Seen: 110 times

Last updated: May 08