New Question
0

V-magine uses my gateway as the dashboard IP and not the IP of the controller

asked 2017-02-20 21:06:30 +0300

ivovanoerd gravatar image

updated 2017-02-20 21:08:32 +0300

V-magine uses my gateway as the dashboard IP and not the IP of the controller so when i browse to 10.0.1.1 i get the dashboard :/ posted the settings i used in the image anyone know why this happens?

image description

edit retag flag offensive close merge delete

Comments

Hi, can you please upload a link to the v-magine.log file? E.g. on dropbox, pastebin, etc

alexpilotti gravatar imagealexpilotti ( 2017-02-20 21:15:48 +0300 )edit

Additionally, can you please post the network controller's configuration in: /etc/sysconfig/network-scripts/ifcfg-mgmt-ext ?

alexpilotti gravatar imagealexpilotti ( 2017-02-20 21:25:46 +0300 )edit

i canceled the install last night but i wil rerun it now with the same settings and post it when i am done

ivovanoerd gravatar imageivovanoerd ( 2017-02-20 21:28:13 +0300 )edit

Thanks. Based on settings I expect to see your controller's management interface set to 10.0.1.149.

alexpilotti gravatar imagealexpilotti ( 2017-02-20 21:39:45 +0300 )edit

http://pastebin.com/jLVrhxsD https://i.imgur.com/gcaCpw9.pnghttps://i.imgur.com/vxueGQ3.png it happend again the dashboard is on 10.0.1.1 again and my whole network becomes unresponsive because both my router and the controller are competing for a single ip.

ivovanoerd gravatar imageivovanoerd ( 2017-02-20 23:29:58 +0300 )edit

Network configuration looks good, can you please send the output of "ip addr" in the controller?

alexpilotti gravatar imagealexpilotti ( 2017-02-20 23:47:10 +0300 )edit

Note: you can disconnect the controller VM from the vSwitch while investigating the issue. This way you can avoid issues with the network traffic.

alexpilotti gravatar imagealexpilotti ( 2017-02-21 01:32:06 +0300 )edit

yes thats what i did i just gave it a vlan ID that was not in use, currently not at my pc ill report in later. Thanks a lot for helping tho!

ivovanoerd gravatar imageivovanoerd ( 2017-02-21 01:35:08 +0300 )edit

i was just retrying the install and now it gets stuck on this: https://i.imgur.com/fDXaw59.png is there any way i can fully delete it and retry, like does it store things in temp folders?

ivovanoerd gravatar imageivovanoerd ( 2017-02-21 16:23:54 +0300 )edit

When you redeploy it, it wipes out the controller VM and starts from scratch, there are no "leftovers" from previous runs

alexpilotti gravatar imagealexpilotti ( 2017-02-21 16:29:25 +0300 )edit

ah ok it worked a few times but now it keeps hanging there, might reinstall server 2016 just to be sure.

ivovanoerd gravatar imageivovanoerd ( 2017-02-21 16:32:39 +0300 )edit

thanks again for helping, ill try again when the bug is fixed. :P

ivovanoerd gravatar imageivovanoerd ( 2017-02-21 21:09:20 +0300 )edit

What we have so far: apparently the nova.conf configured by RDO is corrupted, causing the following issues. Investigating the cause on the RDO IRC channel.

alexpilotti gravatar imagealexpilotti ( 2017-02-21 21:28:49 +0300 )edit

More details, in case others have the same issue: lots of CentOS packages got updated on Feb 20th, causing the regression. Working on narrowing down the issue: http://mirror.centos.org/centos/7/cloud/x86_64/openstack-newton/?C=M;O=D

alexpilotti gravatar imagealexpilotti ( 2017-02-22 02:17:12 +0300 )edit

Found the issue: the python2-ryu package is broken. As I was suspecting we're not the only ones complaining: https://ask.openstack.org/en/question/103016/packstack-requirement-for-python-tinyrpc-breaks-installation/

alexpilotti gravatar imagealexpilotti ( 2017-02-22 04:33:42 +0300 )edit

Workaround: in install-rdo.sh, before running packstack --answer-file, add: exec_with_retry 5 0 /usr/bin/rpm -Uvh --nodeps https://buildlogs.centos.org/centos/7/cloud/x86_64/openstack-newton/common/python2-tinyrpc-0.5-2.el7.noarch.rpm

alexpilotti gravatar imagealexpilotti ( 2017-02-22 04:35:18 +0300 )edit

Thanks for the status updates! ill retry the install after the issue is fixed, I am not in a rush.

ivovanoerd gravatar imageivovanoerd ( 2017-02-22 13:34:31 +0300 )edit

Status update: it still happens it assigns 10.0.1.1(also my gateway) to one of the interfaces: https://i.imgur.com/v6v7SdH.png

ivovanoerd gravatar imageivovanoerd ( 2017-02-22 20:28:54 +0300 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-02-22 23:04:23 +0300

alexpilotti gravatar image

updated 2017-02-22 23:05:26 +0300

This issue has been solved by setting in:

resources/install.rdo.sh

the following line:

openstack-config --set $ANSWER_FILE general CONFIG_PROVISION_OVS_BRIDGE n

If not set, in some circumstances RDO assign the IP of the gateway to br-ex interface, causing a conflict of IPs on the network.

The fix has been committed and released in the v-magine installer available for download.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-02-20 21:06:30 +0300

Seen: 448 times

Last updated: Feb 22 '17