New Question
0

[SOLVED] neutron-ovs-agent not register itself, and vxlan connection not built up

asked 2017-04-03 13:45:47 +0300

Laci gravatar image

updated 2017-04-05 09:03:54 +0300

Dear Team,

I have a working newton environment, I would like to use a hyper-v compute node. The nova compute works as expected, but I have problem with neutron openvswitch agent. I followed https://cloudbase.it/open-vswitch-2-5... in order to install openvswitch on windows 2012 R2 server. Everything looks like (there is no any error in log files). But neutron-ovs-agent not listed in neutron agents on controller. 'ovs-vsctl show' not shows any vxlan tunnel.

ovs-vsctl show

e8bb9f38-f088-439c-a489-e3c567cbe013 Manager "ptcp:6640:127.0.0.1" Bridge br-int Port br-int Interface br-int type: internal Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} Bridge br-tun Port br-tun Interface br-tun type: internal Port patch-int Interface patch-int type: patch options: {peer=patch-tun} Bridge br-provider Port br-provider Interface br-provider type: internal Port provider Interface provider

neutronovsagent.conf:

[DEFAULT]

verbose=true

debug=true

control_exchange=neutron

policy_file=C:\Program Files\Cloudbase Solutions\OpenStack\Nova\etc\policy.json

rpcbackend=neutron.openstack.common.rpc.implkombu

logdir=C:\OpenStack\Log\ logfile=neutron-ovs-agent.log

[agent] tunneltypes = vxlan enablemetrics_collection=false

[SECURITYGROUP] enablesecuritygroup=true firewall_driver = openvswitch

[ovs] localip = 172.17.2.4 tunnelbridge = br-tun integrationbridge = br-int tenantnetworktype = vxlan enabletunneling = true bridge_mappings = provider:br-provider

[oslomessagingrabbit] rabbithost = 172.17.1.1 rabbitport = 5672 rabbituserid = openstack rabbitpassword = a62e6d11095ff403e43294741ae9d4d6da3a56e10192339837654355efb4

neutron-ovs-agent.log

2017-04-03 12:21:40.219 4284 INFO neutron.common.config [-] Logging enabled!

2017-04-03 12:21:40.220 4284 INFO neutron.common.config [-] C:\Program Files\Cloudbase Solutions\OpenStack\Nova\Python27\Scripts\neutron-openvswitch-agent-script.py version 9.0.1.dev14

2017-04-03 12:21:40.226 4284 WARNING osloconfig.cfg [-] Option "rabbithost" from group "oslomessagingrabbit" is deprecated for removal. Its value may be silently ignored in the future.

2017-04-03 12:21:40.226 4284 WARNING osloconfig.cfg [-] Option "rabbitport" from group "oslomessagingrabbit" is deprecated for removal. Its value may be silently ignored in the future.

2017-04-03 12:21:40.227 4284 WARNING osloconfig.cfg [-] Option "rabbitpassword" from group "oslomessagingrabbit" is deprecated for removal. Its value may be silently ignored in the future.

2017-04-03 12:21:40.229 4284 WARNING osloconfig.cfg [-] Option "rabbituserid" from group "oslomessagingrabbit" is deprecated for removal. Its value may be silently ignored in the future.

2017-04-03 12:21:40.233 4284 INFO ryu.base.appmanager [-] loading app neutron.plugins.ml2.drivers.openvswitch.agent.openflow.native.ovsryuapp

2017-04-03 12:21:40.694 4284 INFO ryu.base.app_manager [-] loading app ryu.app.ofctl.service

2017-04-03 12:21:40.697 4284 INFO ryu.base.appmanager [-] loading app ryu.controller.ofphandler

2017-04-03 12:21:40.698 4284 INFO ryu.base.appmanager [-] instantiating app neutron.plugins.ml2.drivers.openvswitch.agent.openflow.native.ovsryuapp of OVSNeutronAgentRyuApp

2017-04-03 12:21:40.700 4284 INFO ryu.base.appmanager [-] instantiating app ryu.controller.ofphandler of OFPHandler

2017-04-03 12:21:40.700 4284 INFO ryu.base.app_manager [-] instantiating app ryu.app ...

(more)
edit retag flag offensive close merge delete

Comments

Hello Laci! Make sure that you are using OVS 2.6.1 on the Windows compute node since that comes with support for the openvswitch firewall_driver from OpenStack. Also please make sure you have in the config file under [ovs] "ovsdb_interface = vsctl" and "of_interface = ovs-ofctl". Thanks, Alin

abalutoiu gravatar imageabalutoiu ( 2017-04-04 20:51:33 +0300 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-04-05 09:02:40 +0300

Laci gravatar image

Problem solved!

I udated '[ovs]' section in neutron-ovs-agent.conf as abalutoiu suggested. Vxaln tunnels built up, controller was able to start instance on hyper-v compute node.

Thank you!

Bests

Laci

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-04-03 13:45:47 +0300

Seen: 255 times

Last updated: Apr 05