New Question
0

I want to add to hyper-v compute node to ocata openstack system, i installed it, but it gives an error "Filter ImagePropertiesFilter returned 0 hosts" ?

asked 2018-01-08 09:22:07 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

In Hyper-v server, nova-compute log includes warning, that "excluding nova compute monitors cpu monitor virt_driver not list of enable. Not in list of enabled monitors" Could you help me ? Do you have any idea ?

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2018-01-09 14:20:49 +0200

Claudiu Belu gravatar image

Hello,

The warning you've mentioned in the Hyper-V nova-compute logs has nothing to do with not being able to spawn instances.

The error you've mentioned in the title is a nova-scheduler typical error, meaning that it could not find a proper host for your request. If the ImagePropertiesFilter filter failed, it probably means that the image you're trying to use doesn't have the right properties for Hyper-V (hypervisor_type=hyperv, disk-format=vhd).

A few other things to keep in mind:

  • Since you're using Ocata, you have to be extra careful when adding new compute nodes. Nova cells became mandatory in Ocata, and new compute nodes are not mapped to any nova cell and will be ignored by the nova-scheduler. After you've mapped the new compute nodes to nova cells, you'll need to restart the nova-scheduler and placement-api services in order for them to be taken into account.

  • One common mistake is using VXLAN neutron networks while the Hyper-V compute nodes only have Neutron Hyper-V Agent as an L2 agent. This agent does not support VXLAN, and you should use Windows OVS and the neutron-ovs-agent [1]. This agent and its necessary configurations are automatically created by our OpenStack Nova Installer starting with the Pike release.

  • If you are using VLAN neutron networks, then the Neutron Hyper-V Agent will be just fine, just keep in mind that you'll have to configure your Neutron controller to use the hyperv mechanism_driver by editing the file /etc/neutron/plugins/ml2/ml2_conf.ini, installing networking-hyperv (pip install networking-hyperv==4.0.0 - 4.0.0 is the released version for Ocata), and restart your neutron-server service. If you check the neutron-server logs, you should see that the hyperv mechanism driver has been initialized. For more details, check [2]

[1] https://cloudbase.it/open-vswitch-2-5...

[2] https://cloudbase.it/neutron-hyper-v-...

Best regards,

Claudiu Belu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-08 09:22:07 +0200

Seen: 172 times

Last updated: Jan 09