New Question
0

v-magazine openstack 2 Network Adapter Problems [closed]

asked 2017-05-05 07:44:21 +0200

pcminitech gravatar image

I deployed openstack with v-magazine everything works great on the current setup. I want to add 2 external network adapter with hyper-v virtual switch.

  1. Build virtual switch
  2. Add to the openstack-controller
  3. ip a the adapter is eth4
  4. ovs-vsctl add-br br-eth4 ovs-vsctl add-port br-eth4 eth4
  5. Following those instructions, make sure that both externalnetworkbridge and gatewayexternalnetworkid are unset in l3agent.ini.
  6. type_drivers = local,flat,gre,vxlan
  7. flat_networks = *
  8. networkvlanranges = physnet1:500:2000,physnet2 bridge_mappings = physnet1:br-data,physnet2:br-eth4
  9. openstack-service restart neutron
  10. neutron net-create WANNetwork2 --provider:networktype flat --provider:physical_network=physnet2 --router:external=true
  11. Add subnet 104.234.239.0/24 and pool of ips and build router add private subnet 10.0.1.0/24 add private subnet to router and put the gateway to router on the real world router 104.234.239.40 Can ping ips internal and to the bridge can't ping real router and access rule allow ping out.

The other network is fine and 10.0.0.0/24 and router and 192.168.1.0/24 public ip on the external network.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by pcminitech
close date 2017-05-15 22:06:38.097582

1 answer

Sort by » oldest newest most voted
1

answered 2017-05-05 13:54:26 +0200

danardelean gravatar image

Hi,

Please make sure that "Enable MAC address spoofing" is enabled on the openstack-controller VM network adapter in which br-eth4 is connected. You find this in Advanced Features tab.

Thank you.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-05-05 07:44:21 +0200

Seen: 64 times

Last updated: May 05