New Question

PortBindingFailed: Binding failed for port f168d8e9-fbbb-4e42-a371-d910fe4bc560

asked 2017-02-13 12:58:47 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi Team,

I have installed openstack (newton release) controller machine in centOS 7 and added windows 2016 hyper-V as compute host.

Both controller and windows hyper-v are VM and running in windows 2016

[root@controller ~]# nova hypervisor-list +----+---------------------+-------+---------+ | ID | Hypervisor hostname | State | Status | +----+---------------------+-------+---------+ | 1 | wincompute | up | enabled | +----+---------------------+-------+---------+

when i tried to add new instance it shows the error as "PortBindingFailed: Binding failed for port f168d8e9-fbbb-4e42-a371-d910fe4bc560"

Nova compute log file :

Neutron hyper agent file :

Nova Config file :

Also I have created a local network with external checkbox through openstack dashboard. I unable to find any documentation related to network setup for hyper-V.

Please let me know how to resolve this issue.

Regards, Loges

edit retag flag offensive close merge delete


Hello Loges! I see that you are trying to boot a qcow2 image on Hyper-V. Only vhd/vhdx images are supported on Hyper-V, could you please convert the image to vhd and then boot the VM? (qemu-img image-convert -f qcow2 -O vhdx <qcow2_image_name> <vhd_image_name>) Paste the log here after that. Thanks!

abalutoiu gravatar imageabalutoiu ( 2017-02-13 16:19:17 +0300 )edit

Can you please confirm that this question is not a duplicate of: ?

alexpilotti gravatar imagealexpilotti ( 2017-02-19 16:55:03 +0300 )edit

It's almost same question.

Logeswaran gravatar imageLogeswaran ( 2017-02-22 09:03:35 +0300 )edit

Please set one of the two as duplicate, it's pointless and inefficient to try to help you on two questions on the same topic.

alexpilotti gravatar imagealexpilotti ( 2017-02-24 15:52:01 +0300 )edit

3 answers

Sort by » oldest newest most voted

answered 2017-02-16 20:34:12 +0300

avladu gravatar image

updated 2017-02-16 20:35:39 +0300


You require networking-hyperv package on the linux network api node.

You can use pip to install it: pip install networking-hyperv

Thanks, Adrian Vladu

edit flag offensive delete link more


Adrian, thanks for your response. I ran this command on network API node and also in hyper-v host also. But I'm still receiving the same port binding fail error. For testing purpose, I'm trying with only one nic. Also I have created the windows host as NESTEDVM in windows 2016. Will it be a problem?

Logeswaran gravatar imageLogeswaran ( 2017-02-17 11:25:23 +0300 )edit

You need to create either a flat network, either a vlan network (on the logs you mention, there is no information on the actual types of the neutron networks). Make sure this is the case, by checking: neutron net-show <network-id>

avladu gravatar imageavladu ( 2017-02-17 14:27:16 +0300 )edit

If you check this URL you can find the network configuration & binding details. Should we need to have 2 NICs for windows hypervisor. I'm using only one NIC for both openstack & windows hypervisor for testing purpose.

Logeswaran gravatar imageLogeswaran ( 2017-02-18 10:12:24 +0300 )edit

I'm still not sure what need to be done... Clueless :(

Logeswaran gravatar imageLogeswaran ( 2017-02-22 09:08:44 +0300 )edit

You need the neutron net-show <network-id> information or the admin network view in the pasteboard (not the project view). You need to make sure you use either vlan or flat network types.

avladu gravatar imageavladu ( 2017-02-22 14:49:32 +0300 )edit

answered 2017-02-14 05:47:13 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have tested the settings from my end and still getting any port binding failed error. I have added nanoserver VHD as glance image. Here is my configuration screenshot openstack systeminformation screenshot :

I will explain my current setup : My host server is windows 2016 and I have created 2 VM. one VM is for openstack controller and open VM (nested) is for nova compute.

I have created flat network in openstack. Here is the network port configuration screenshot :

Also I have only one network card and I'm testing this setup as POC. Also I have attached the nova-compute log and configuration file.

Nova log : Nova config : neutronhypervagent config :

I'm really not sure what need to be done from my end. Can you please help me on this?

Regards, Loges

edit flag offensive delete link more


Guys, can anyone help on this?

Logeswaran gravatar imageLogeswaran ( 2017-02-15 08:52:07 +0300 )edit

answered 2017-02-13 17:10:07 +0300

Claudiu Belu gravatar image


As previously mentioned, Hyper-V supports only VHD / VHDX images. You can find some already prepared images here: [1]

Secondly, make sure that you have the hyperv mechanism driver added in the Neutron server's ml2_conf.ini file in the mechanism_drivers list. Keep in mind that the neutron-hyperv-agent agent doesn't support VXLAN networks [2]. If you want VXLAN / GRE or other network types, you should take a look at Windows OVS + neutron-ovs-agent instead.




Best regards,


edit flag offensive delete link more


Claudiu, I have changed all the settings as specify in the document still receiving the error. Can you please help me out. Check the below post about error logs & config files.

Logeswaran gravatar imageLogeswaran ( 2017-02-15 08:53:29 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-02-13 12:58:47 +0300

Seen: 5,099 times

Last updated: Feb 16 '17