New Question
0

DHCP not assigning IP

asked 2018-11-23 15:55:23 +0200

tric78 gravatar image

Hi,

after reading and fighting a lot i can't manage to do this working, so my last chance is someone can help me..

I have configured a controller (Hyper-V VM with CentOs) from zero following the openstack official guides, and the cloudbase HyperVNovaComputeQueens1700 with neutron agent in 2 standalone (no domain) Hyper-V hosts (one of them hosts the controller)

Everything is working OK except the instances are not getting IP address. If I assign the IP manually, I can ping and communicate between controller and instance. In the controller, if i sniff traffic with tcpdump i can see the DHCP request, but not the response. In the logs i see the dnsmasq in the controller assign the IP.

In my neutronhypervagent.conf i have these lines: *

...
[SECURITYGROUP]
firewall_driver=hyperv
enable_security_group=true

but in linuxbridge_agent.ini in the controller i have these:

[securitygroup]
 firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver
enable_security_group= true

is this config correct?

what else could i do for troubleshooting the problem?

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2018-11-25 12:29:26 +0200

lpetrut gravatar image

Hi,

What network type are you using (flat, vlan, tunnels)? That config looks fine. You're using Hyper-V switch ACLs on the Hyper-V side and iptables on the controller for the security groups.

So, since the dnsmasq part is ok, I'd check the dhcp namespace on the controller. You may check if the DHCP requests get there as well. Also, make sure that you don't have other DHCP servers replying to your requests.

Regards, Lucian

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-23 15:55:23 +0200

Seen: 13 times

Last updated: Nov 25