New Question
0

Problems with static network config.

asked 2019-09-19 20:44:23 +0300

I configure the network with network_data.json

{ "services": [ { "type": "dns", "address": "10.22.44.206" } ], "networks": [ { "networkid": "a7ffd6e4-3600-4d21-a785-4c1f89101b6f", "type": "ipv4", "netmask": "255.255.255.0", "link": "Ethernet0", "routes": [ { "netmask": "0.0.0.0", "network": "0.0.0.0", "gateway": "10.22.44.1" } ], "ipaddress": "10.22.44.102", "id": "network0" } ], "links": [ { "ethernetmacaddress": "52:54:00:16:7e:29", "mtu": 1500, "type": "bridge", "id": "Ethernet0", "vif_id": "6c24009c-9c51-4a01-bccb-0488fc3d539d" } ] }

It looks like the config completes but gets rolled back by a problem with WinRM.

2019-09-18 17:08:33.629 4280 INFO cloudbaseinit.plugins.common.networkconfig [-] Setting static IP configuration on network adapter "Ethernet0". IP: 10.22.44.102, prefix length: 24, gateway: 10.22.44.1, dns: ['10.22.44.206'] 2019-09-18 17:08:33.885 4280 DEBUG cloudbaseinit.osutils.windows [-] Removing existing IP address "10.22.44.102" from adapter "Ethernet0" setstaticnetworkconfig c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\osutils\windows.py:920 2019-09-18 17:08:36.338 4280 ERROR cloudbaseinit.init [-] plugin 'NetworkConfigPlugin' failed with error '<x_wmi: the="" client="" cannot="" connect="" to="" the="" destination="" specified="" in="" the="" request.="" verify="" that="" the="" service="" on="" the="" destination="" is="" running="" and="" is="" accepting="" requests.="" consult="" the="" logs="" and="" documentation="" for="" the="" ws-management="" service="" running="" on="" the="" destination,="" most="" commonly="" iis="" or="" winrm.="" if="" the="" destination="" is="" the="" winrm="" service,="" run="" the="" following="" command="" on="" the="" destination="" to="" analyze="" and="" configure="" the="" winrm="" service:="" "winrm="" quickconfig".="" (-2144108526,="" 'the="" client="" cannot="" connect="" to="" the="" destination="" specified="" in="" the="" request.="" verify="" that="" the="" service="" on="" the="" destination="" is="" running="" and="" is="" accepting="" requests.="" consult="" the="" logs="" and="" documentation="" for="" the="" ws-management="" service="" running="" on="" the="" destination,="" most="" commonly="" iis="" or="" winrm.="" if="" the="" destination="" is="" the="" winrm="" service,="" run="" the="" following="" command="" on="" the="" destination="" to="" analyze="" and="" configure="" the="" winrm="" service:="" "winrm="" quickconfig".',="" (0,="" none,="" 'the="" client="" cannot="" connect="" to="" the="" destination="" specified="" in="" the="" request.="" verify="" that="" the="" service="" on="" the="" destination="" is="" running="" and="" is="" accepting="" requests.="" consult="" the="" logs="" and="" documentation="" for="" the="" ws-management="" service="" running="" on="" the="" destination,="" most="" commonly="" iis="" or="" winrm.="" if="" the="" destination="" is="" the="" winrm="" service,="" run="" the="" following="" command="" on="" the="" destination="" to="" analyze="" and="" configure="" the="" winrm="" service:="" "winrm="" quickconfig".',="" none,="" none,="" -2144108526),="" none)&gt;':="" wmi.x_wmi:="" <x_wmi:="" the="" client="" cannot="" connect="" to="" the="" destination="" specified="" in="" the="" request.="" verify="" that="" the="" service="" on="" the="" destination="" is="" running="" and="" is="" accepting="" requests.="" consult="" the="" logs="" and="" documentation="" for="" the="" ws-management="" service="" running="" on="" the="" destination,="" most="" commonly="" iis="" or="" winrm.="" if="" the="" destination="" is="" the="" winrm="" service,="" run="" the="" following="" command="" on="" the="" destination="" to="" analyze="" and="" configure="" the="" winrm="" service:="" "winrm="" quickconfig".="" (-2144108526,="" 'the="" client="" cannot="" connect="" to="" the="" destination="" specified="" in="" the="" request.="" verify="" that="" the="" service="" on="" the="" destination="" is="" running="" and="" is="" accepting="" requests.="" consult="" the="" logs="" and="" documentation="" for="" the="" ws-management="" service="" running="" on="" the="" destination,="" most="" commonly="" iis="" or="" winrm.="" if="" the="" destination="" is="" the="" winrm="" service,="" run="" the="" following ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2019-09-24 20:00:35 +0300

avladu gravatar image

Hello,

The issue you got is a known one and it happens because of a bug in PyMI package. A fix is under review https://github.com/cloudbase/PyMI/pul... .

What you can do is to make sure that when you generate the image, you enable winrm by just running: winrm quickconfig or to enable the cloudbase init winrm plugin to run before the network plugin.

Thank you,
Adrian Vladu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-09-19 20:44:23 +0300

Seen: 18 times

Last updated: Sep 24